Trying to get CUPS to install a network printer not connected directly

I had this working easily in raspian, but for whatever reason, network changes, firewall, stupidity… I can’t seem to get my HP network printer to actually install. I keep getting an error and it claims it can’t find the PPD file when I never chose that option at all? It clearly sees the network printer already. I have 3 different choices as well.

what should I do? I am new to dietpi, but I am loving this OS!

Many thanks

Drivers for CUPS can be a pain
How to add a Foomatic PPD to CUPS? (

Might be in the manufacturers driver package or from a opensource repostiory
Printer List | OpenPrinting - The Linux Foundation

Do you have a desktop/vncserver setup on your printserver?

CUPS works nowadays driverless and with ipp-usb even via USB.

like said, this just worked from the raspbian install. I am kind of stumped. Thanks for the reply I will check the links out

I tried driverless and anything that was seen. It kept erroring out regarding a PPD file when I mever chose that option.

do I still need samba server? If not, great… if so, i tried that as well.

You need mDNS/DNS-SD support via Avahi.

At least the Avahi-Daemon we install. This should be done automatically as part of our install script.

You can check with ippfind if an IPP printer can be discovered.

Thanks for the help.

No matter what I do it doesn’t work. Im going to just put this one on the back burner. I have other things I am trying to get to work in dietpi that are also proving problematic.

{EDIT} I ended up going back to raspbian and it worked without any problems whatsoever.

I guess there are packages available ootb on plain Raspbian, which we remove on our conversion into DietPi. Would be interesting to know which packages are missing on our side. :thinking:

I guess just do a fresh install and only install ssh, and cups. I used openssh instead of dropbear also. Oh and I also had pihole installed too. If it still works for you at that point, then I have no idea.

Dietpi is awesome imo and I still use it for a presence device on a pi zero as well.

Let me know how it pans out if you end up giving it a go.

I had CUPS running in the past with a regular network printer HP mfp 277dw connected via Ethernet

The HP mfp 277dw supports “Apple AirPrint, Mopria-certified” and can therefore be run driverless.

Honestly, I’m not sure how I could test this as for my printer it’s working. At least it was working in the past. :thinking:

Can you run cups-browsed -v and have a look for possible errors?

I tested with my Lexmark E332n, connected to my wifi router.
At first I could add it in cups but when I tried to print, it said “not found”.
With cups-browsed I saw, that it was constantly reconnecting. I changed the network cable and now it prints, at least rubbish. I think I chose the wrong driver so I only get quirky signs instead of the test page :sweat_smile:

Looks like no IPP Everywhere support and only this PDLs:

PCL 6 Emulation, Personal Printer Data Stream (PPDS), PostScript 3 Emulation

Therefore, the Generic PostScript Printer driver should work.