Tried to setup NFS. Stuck after boot now

Creating a bug report/issue

Required Information

  • DietPi version v8.20.1


I just installed Dietpi on Hyper-V. (Windows 11)
After days of trying to setup a proper backup solution for my Raspis, I finally
installed a NFS Server as Backup Server for my Dietpi Raspberrys.

After not beeing able to reach the NFS Server, I thought to ask for help here.
Connection via SSH was also not possible so I thought I start LXDE and connect via VNC.

I installed LXDE and configured it to run on startup.
This is where I stuck now. The system does not boot anymore.

Nothing happens here anymore.
What can I do?

Thanks and regards

So you have some RPi’s and you want to backup to the virtual machine via LAN?
I think you don’t need ssh or VNC, you could just use the terminal from the VM to manage the backup server.

But the main problem is, that you can’t connect to the VM from your network? Seems like some config issue of the VM. I personally only used Virtual Box, where you have to use a virtual network bridge, to get access from LAN to the VM.

@HyperCriSiS is the VM IP address from your local network address range?

Yes (concerning backup) :slight_smile:
Atm I am not able to test anything, because the VM stucks at this screen after boot.

what about the IP address range from your local network? Does it fit to the one from VM used?

No, my local network is
Do I need to configure something to route between the network?
Thought this is done automatically through the VM bridge, but I read now, that seems to be the issue.

Problem now is, that the VM is completely unusable. It just stucks at this screen above after I installed LXDE and set it to auto start at boot.

I have put the VM in the same subnet now, but it still stucks at the same spot.

are you able to connect via SSH now?

No, still connection time out. SSH should work out of the box right? Or could I have forgot something?

SSH should work ootb. Can you try a new VM with correct network interface within HyperV settings? Usually the VM should get a IP address from your local network address range and you should be able to connect.

hmm strange, still not working.
Created new external switch and set it prior installation:

Is this not the right config?

hmm ok still not working. Just messed up the IP and thought it works but was the other Dietpi system.
Now I even can’t login anymore. It does not accept the newly set password :frowning:

I begin from scratch again.

It seems that I can access every resource except the Host system ones.

Oh man, after days of fight with NFS, EXT4 on Windows, Samba and Linux permissions I finally have an easy solution.
Hope this works now as intended :sweat_smile:

I disabled/enabled Hyper-V.
Created new VM.
Added external adapter.
Assigned static IP and gateway.
The VM can finally also access the Host. As I read this is normally done trough the default (internal) swtich.
No idea why it did not work before.

NFS also working now! :slight_smile:


You found the solution by yourself and I thank you for sharing this here. :slight_smile:

This is one of the reason I use VirtualBox instead of Hyper-V :rofl: