System crashed randomly


I’m using dietpi v6.22.3 on my RPi Zero W with several applications. Randomly (once peer week, every 2 weeks,…) the system is crashing and no application on the system is available (e.g. pihole, ssh, …). Also a ping to the dietpi-system is not able.

I created a bugreport with reference code: 5c36dc34-53c6-4f9c-b6a5-a88242e3acdc

Do you need more information from my side?


Thanks for your report. I will check your bug report.

Meanwhile please check your RAM usage by times (free -m or htop) as this can be a reason for crashes. Also check dmesg for red coloured error outputs, e.g. about insufficient voltage or disk corruption.

The time when you sent the bug report at least no issue with RAM or dmesg.

However I noticed you have dhcpcd installed. This is done by Pi-hole but is actually not required. The service starts with failure anyway since there is no interface configured to use it. On DietPi we use isc-dhcp-client but with Pi-hole you need a static IP anyway. To resolve the failure:
systemctl disable dhcpcd
What works as well:
apt purge dhcpcd

  • But Pi-hole updates will reinstall it, so skip this…

Also you have snmpd.service enabled but it fails due to some missing PCI API file in /proc. The SNMP server generally is to centrally configure network devices. Not sure where it comes from or if you require it. Might have been installed together with “FHEM Home Automation”. If you did not manually install you can either do:
apt purge snmpd

  • Check if some required APT package would be removed as well and in case press “n” to cancel the uninstall. If it is no dependency of any other installed package, confirm with “y”.
  • Otherwise you can disable the service similar to dhcpcd: systemctl disable snmpd

You have installed stubby DNS resolver. On Debian Stretch, resolvconf includes all required things, however stubby seems to increase privacy/security and looks like a good modern enhancement. But it is not offered for Stretch natively, only on Buster. Don’t know from where/how you installed it but it reports an error:
systemd[1]: [/lib/systemd/system/stubby.service:7] Unknown lvalue ‘CacheDirectory’ in section ‘Service’

  • This is AFAIK due to the Stretch systemd version does not support this syntax/setting yet. You might want to fix this by doing:
    sed -i ‘s/^CacheDirectory/#CacheDirectory’ /lib/systemd/system/stubby.service
    systemctl daemon-reload
    But it does not harm much.

More important than all above:

  • You have dnsmasq installed beside Pi-hole.
  • Since version 4 Pi-hole has dnsmasq included so both conflict.
  • Verify you are on current Pi-hole version, e.g. pihole -up
  • Then purge dnsmasq: apt purge dnsmasq

But all the above should not result in a system crash. So please watch your RAM usage and dmesg by times for errors.

Hello MichaIng,

big thanks to you and your enormous answer. I will check all your lines with my system and come back to this thread.