Supported wireless dongles?

Pretty massive bug - Pi Zero has no networking by default, so you have to use a USB dongle. There are none supported without downloading a driver. You can’t complete install without a network either.

This doesn’t work on a Pi Zero without being able to download and install drivers for the network without an internet connection.

I could download files and put them in the “boot” partition if I knew say to download… but there’s nothing to tell me.

I could order a dongle that has drivers in the distro if there were any, but there’s no list to tell me so presumably there aren’t.

Is it safe to assume this just isn’t compatible with the Pi Zero?

Could I buy a Pi Zero W, install on that, then put the card plus drivers in a standard Zero?

Hi thanks for your report.

Actually three is a bunch of WiFi dongle drivers pre-installed, all obvious packages available. So it’s not a bug, but seems a quite rare WiFi dongle you use. These are the driver packages we pre-install:

If those do not support, is there another ATP package available in Debian repo that does or do you need to download/install one from manufacturers?

Perhaps we can add a feature that allows to place driver package to auto pre-install into the boot directory :thinking:. For now I think it you need to download and place the driver package from you desktop, place it onto SDcard and install it manually. You should be able after first run update fails, to install the diver and rerun dietpi-software to complete.


I actually have a box of about 30 or so WiFi dongles from all kinds of places. Most of them I know work with the Pi2 under Raspbian Jessie, as that was my method of testing. If they worked, I kept them, if they didn’t, they got dumped.

Out of all of those, maybe a handful give me something, but not anything that works. The RTL8188CU based devices seem to be most “live”, but they don’t connect and don’t give me an IP address. The system sees the device, but complains about power management failing. I could understand one failing, but when they all do the same that seems suspect. I’ve got them plugged into a USB Hub that is powered (up to 2Amp per device - 3.5 Amp power supply) and the Pi has been tried both from the powered hub and its own power supply, but the results are exactly the same.

Is there anyway I can find out exactly what chipsets are covered by firmware-atheros, firmware-brcm80211 and firmware-iwlwifi? Apparently none of those I have are supported properly.

I’ve found I can “break” the install and get a command line if I keep stabbing CTRL-C until it exits. I don’t know how to install a driver manually though - I’ve only ever installed with apt-get which of course wants the Internet.

I don’t know what driver I need, but I will sit here and try hundreds one by one if that’s what I have to do to find one that works. I’'ll even run a Linux Live USB on my main laptop and compile drivers if that’s what I have to do. The problem at the moment is it’s just blind guesswork, because there’s nothing to tell me what I should be doing, or where to manually obtain packages.

The device I’d like to use ideally is 0BDA:A811 because it has a removable aerial.

The device that almost worked is 0BDA:8176

I have ordered:

Alfa Network AWUS036NHA - USB WiFi Adapter, 150 Mbps, 802.11b/g/n, RP-SMA, AR9271L Atheros Chipset

If I have to use those for the Pi Zers I have, it would have been cheaper just to buy Pi3!!

WOW wait, do not order WiFi dongles now as a guess in the blue. At least your second mentioned dongle should work and the issue should be not the dongle but something else about system/setup! :open_mouth:

It seems to be a widely known issue that this WiFi adapter 0BDA:8176 is until now badly supported by current repos. Even the provided deb package from manufacturer seems to not work in many cases. Instead if was necessary to build the drivers oneself:

Hmm but you say you tried many of them and have power supply errors?
Btw, I forgot firmware-ralink + firmware-misc-nonfree + firmware-realtek above. These are as well pre-installed and the last one is the one that should be relevant in your case.

0BDA:8176 == RTL8812AU
And this is indeed not included in the driver package:

  • RTL8812AE is, but yours not :face_with_raised_eyebrow:.

0BDA:8176 == RTL8188CU/RTL8192CU
This IS supported by the driver package, thus should work out of the box.

According to the other issues you report, I guess it is some deeper problem. Lets move the discussion to GitHub, as Fourdee will notice faster there.

I’ve already ordered the network adapter, as it was in the list of devices in the files you posted. I spent a fair while going down the list trying to match chipsets to adapters, but most don’t tell you what chipset they use. Oh well. I’m just desperate to get something working.

This is a fresh download on a new MicroSD card.

I’ve got four Pi Zero devices here to try (several more elsewhere) - they all do the same.

I’ve got quite a few USB hubs around (in use) but the one I’m using is the best of the bunch as it goes blindingly quick for a USB2 hub and has a beefy power supply. I tried a couple of the others - no difference.

The error I’m getting with the RTL8188CU is about Power Management. I’ve been trying to find a log file that might have the actual error in, but no luck so far.

All this hassle and all I actually want is a fast-booting system without tons of crap running in the background that I don’t need, to develop myself some electronic display boards. What I thought was going to be easy has turned into a nightmare after nightmare. The only thing I’ve had working on the Zero so far is a full blown Raspbian, and it’s slloooooooowwww…

Did the WiFi dongle work out of the box on Raspbian?

And did you try different power supplies for the SBC as well?

But please answer on GitHub:

  • I had some other suggestions/questions there and really, Fourdee might help you better with this (and will answer faster there), simply has more experience about different SBCs with different setups/hardware.

They all work out of the box on Raspbian with the Pi2, but of course there’s a wired network available, so I could let it do the updates it needed to install any drivers. Only the RTL8188CU worked on the Zero will full Raspbian.

Hopping over to GitHub…