Support for BanannaPi-M2-ZERO

Would love to see BanannaPI M2-ZERO support. Dosen’t look like the RPI foundation is going to release a new Raspberry PI Zero anytime soon, and most of the newer software requires ARMV7 support which the PI-ZERO dosent have. The BannnaPi M2-Zero is an Excellent replacement hardware wise but lacks the software support of the RPI-Zero.

The BanannaPI is the same form factor with 4 x the cores and more processing power. Would be great to see diet-pi on this board!

Did you try out https://github.com/Fourdee/DietPi/issues/1285 ?

Use this with attached HDMI monitor and keyboard, since WiFi connection might drop while setup, so SSH connection can break.
I guess the ARMbian image will serve as best basis.

You can paste/print errors messages or failures of the script here, so we can get those fixed. Due to the large variety of hardware and system setups it’s hard to guarantee the script running without issue.

Hello. First of all, big tnx for project MichaIng and all maintainers. I am happy owner of nano pi neo 3 with diet pi onboard which runs smoothly few ears and works like a charm. Now a bad news. I trying to get run diet pi with m2 zero. Using general conversion script and in the step of dist upgrade in facing no working wifi.


I assumed that script on stage of removing stuff deleted some networking packages for that board delivered by armbian. I will try to find way around that, but I additional help or pointing to direction is requirted. tnx

Basically known: https://github.com/MichaIng/DietPi/issues/6286#issuecomment-1494793512

So when facing this error, try to “Open subshell” and enter this:

echo 'nameserver 9.9.9.9' > /etc/resolv.conf
exit

Then “Retry”.

On Armbian, NetworkManager manages /etc/resolv.conf and on uninstall this package has be bad habit of clearing that file, breaking DNS resolution, instead of just leaving it untouched (respectively its content). The above command recreates a simple new one, using Quad9 as public DNS server.

I hope this alone is sufficient and that the other parts of the network setup are still in place, i.e. assigned IP address and default route/gateway.

I guess something bigger happened behind a scene. I tried to run iwlist wlan0 scanning in subshell. and it didnt gave any results and finished immediately. /etc/network/interfaces was pretty empty (just 2 lines overthere auto lo something) and no config for wpa_supplicant. I guess on initial stage script removes it. I will try to set nameserver later, but im not sure that is a case. Tnx for fast response.

Update. set up nameserver didnt help. Wifi configured with mntui which was removed during script run. tried manually add wpa_supplicant.conf and /etc/network/interfaces. Succeeded to get ip from router. but didnt fix resovling hosts.

Does nmtui setup wpa_supplicant.conf at all? If so, is it a file or symlink (before you run the installer)? Probably NetworkManager clears wpa_supplicant.conf on uninstall just like /etc/resolv.conf when it does manage it.

Hmm, if /etc/resolv.conf does have a valid nameserver entry now, then Internet is probably still not there? Does ot work to ping any other global IP?