Subsonic/HifiberryDAC+ audio issue

I’ve set the audio device using the config but I can’t get Subsonic to use the DAC. I’ve also reset , removed the DAC and used the onboard hdmi/3mm but I can get subsonic to output audio in Jukebox mode. I’ve use a hifiberry health check script and I can get audio output. It seems Subsonic or Java is not recognizing the device. I’ve attempted a few things where I try to get the audio device ID as Java sees it in the system but all I see returned is Pulse Audio and no Hifiberry. I can see the highfiberry in the list of sound cards but not in mixers…

Just an odd situation. If anyone had any ideas I’m game.

Have you had any luck with this? I’m trying to get this working with Airsonic/HifiBerryDAC+

No, I can’t get subsonic to output any sound on the pi. I’ve tried the Hifiberry and the standard 3mm. I can get system sound but for some reason when I use my phone app and try to play on server option there is no sound. This would be perfect if I knew how to get it working for that.

There was a post on the Subsonic forums about setting the audio device in java settings but I’m not good enough in linux to be messing with those settings. I tried but never got anything. Would love if someone else had any ideas. I’ll be happy to work with them in testing.

Here is the post to the Subsonic forum. Seems like this is the issue. I’m not sure. The issue I have is I can’t get a list of java audioDev and I’ve tried editing with “bcm2835 ALSA” but nothing works. Just to clarify sound output on my 3mm port works fine… using aplay it’s just subsonic can’t output sound to the 3mm port.