Strange issue while installation on Intel NUC

Hello community
thats my very first post :slight_smile:

I’m using DietPi on a Pi 4 b 2GB for quite some time.
I’m about to build my own cloud storage with nextcloud and I’m afraid my Pi is a bit weak for this task.
So I decided to use my Intel NUC (D34010WYK, i3-4010U, 8 GB) for its more potent hardware.
Because I got in love with DietPi I wanted to use this distro again.

I followed the installation guide (native PC / UEFI), booted from USB, saw the installation screen, the Clonezille screen and after that there was this:

Nextcloud (URL to picture).

Normally I can search for the error code or text but in this case I’m a bit helpless.

Well I tried another USB Stick, modified some UEFI settings, flashed again (with RUFUS) but no change.

The pre installed Linux Mint works flawlessly.

Any ideas?

Thanks in advance

Are you able to connect via SSH from remote? Are you able to flash the image directly to disk?

How can I directly flash to the disk?

Is it possible to flash DietPi when booted in another OS? As mentioned Linux Mint still works on that PC.

It’s like flashing a USB stick. Connect the future system HDD to a running system and flash the image directly onto the HDD like you would do with an USB stick.

probably my fault. on UEFI we have the installer version only. For BOIS we offer a native img file. But not on UEFI.

Theoretically you could the plain Debian netinst as starting point. If this is working, use our DietPi installer to convert into DietPi.

didn’t know that you could use the DietPi installer on top of vanilla Debian netinst

I flashed Debian netinstall to a stick, was able to boot from and saw a normal screen with the installation menu. But either option I choose from I always got this: Nextcloud

Thankfully there is an ‘automate install’. After I hit that, the status LED of the stick flashed for some time and after that the status LED of the network flashed too. Dunno how long to wait, for the installation, screen remains unchanged.

After some time I removed the stick, booted the PC and saw this: Nextcloud

Dunno what to do from this point.

Figured out that I need preseed config for automatic install. Trying to gather more information.

I’m struggling with this preseeding stuff. Dunno what to write into the config, there’s way too many options :frowning:

What kind of monitor do you use?
Is it a very large one, so that a smaller could help for the first instaölation steps?
Could you connect e.g. a VGA monitor?

If yes, i propose to try the DietPi installer at first again.

It’s a 22’’ with 1920x1080. I don’t have any other.

The very first installion menu after booting from USB stick is displayed normally and I can use it normally via keyboard.

It’s driving my nuts…I don’t get this preseeding stuff :frowning:
I can still boot into Linux Mint. Is there an easy way to install debian or dietpi from there?

Do you plan to have a dual boot system? Just out of curiosity, did you try the BIOS version? Strange that even the plain Debian netinst is not working on your system. :thinking:

Well it seems I got the solution.
I loaded bios default settings (on the most current bios version) and tried again with dietpi image and now it seems to work. I got prior the Clonezilla flash screen without the odd screen.

Installation is done and I can see the welcome screen. :hot_face: :partying_face:


thx for sharing your solution.

1 Like

Thank you for standing by me.