Sonarr Issue "Folder is not writable by user Sonarr"

So, I recently moved my root folders to another sever and just like some other users I seem to be having an issue getting my network mounted storage to be writable by sonarr.

Radarr was giving me the same issue but after amending the user and group permissions to dietpi:dietpi this made it start working.

I thought, great, Sonarr should work now. But alas this was not the case and i’m getting the annoying “Folder is not writable by user Sonarr” error message when trying to update the root folder in the series editor for all existing series.

Just to reiterate, network mounted storage is writable by radarr but not sonarr. :thinking:

Version and stats:

  • Raspberry Pi Model: Raspberry Pi 4 Model B Rev 1.1

  • OS: Raspbian 10 (Buster)

  • Docker: No

  • Mono Version: Mono JIT compiler version

  • Browser and Version (Only needed for UI issues): Firefox 85.0.2 (64 bit)

  • Sonarr Version:

  • Sonarr Branch: master

  • Samba version: 4.9.5-Debian

/etc/fstab permissions are set to uid=dietpi,gid=dietpi but I do not have any “file_mode=” or “dir_mode=” entries.

ls -la readout from mount point:

dietpi@DietPi:/mnt/12TbBackup$ ls -la
total 4
drwxrwxrwx+ 1 dietpi dietpi    0 Feb 22 21:42  .
drwxr-xr-x  8 root   root   4096 Feb 20 17:23  ..
drwxrwxrwx+ 1 dietpi dietpi    0 Jan 11 17:26 '$RECYCLE.BIN'
drwxrwxrwx+ 1 dietpi dietpi    0 Jan 14 21:00  3D_Printer_Files
drwxrwxrwx+ 1 dietpi dietpi    0 Feb 14 17:56  Code
drwxrwxrwx+ 1 dietpi dietpi    0 Feb  1 20:33  Documents
drwxrwxrwx+ 1 dietpi dietpi    0 Feb 14 17:05  Games
drwxrwxrwx+ 1 dietpi dietpi    0 Feb 21 11:53  Music
drwxrwxrwx+ 1 dietpi dietpi    0 Feb  7 17:54  Pictures
drwxrwxrwx+ 1 dietpi dietpi    0 Jan 11 20:13 'Raspberry Pi Files'
-rw-r--r--+ 1 dietpi dietpi    0 Feb 22 21:42  sonarr_write_test.txt
drwx------+ 1 dietpi dietpi    0 Jan 12 07:56 'System Volume Information'
drwxrwxrwx+ 1 dietpi dietpi    0 Feb 22 21:22  Video

Any and all help is greatly appreciated


best to my knowledge this is a known issue of Sonarr v2 using Mono v6 not being able to write to CIFS mounts

As well a point on the known issue section of the release notes

Many thanks Joulinar for the information.

After reinstalling Sonarr to V3 I can now add a network drive as root folders. :smiley:

Why did I need to do updgrade to V3 manually instead of being included in apt upgrade as it had done with updgrading to the latest version of radarr?

Well Sonarr V3 is still in beta phase. That’s the reason why your need to update manually.

How do you upgrade it manually?

Simply follow sonarr instructions

ah nice, thanks.

If I uninstall sonarr from the dietpi software centre afterwards is there a chance it will delete some data that V3 will use?

Simply do a dietpi-backup before. If things are missing afterwards, you are able to restore quickly

I know this is an old post (and my first!), but a search brough me here and I’m having the same issue, with setting up Sonarr V3

I just recently moved by plex setup over to dietpi, and now looking to setup sonarr/radarr.

My fstab config is as follows and from the Sonarr wiki, I added the nobrl flag as well.

//192.168.xx.xx/Public /media/UnRaid cifs nobrl,guest,uid=1000,iocharset=utf8 0 0

I can read/write to the drive without issue. But I can’t get sonarr to save the root path.

Do I need to change the guest/uid?

Can you share following

ls -la /media/UnRaid

When I run id, I get:

uid=0(root) gid=0(root) groups=0(root)

So I changed my fstab to a user of root and a id and gid of 0 as follows:

//192.168.xx.xx/Public /media/UnRaid cifs nobrl,username=“root”,password=“xxxxx”,uid=0,gid=0,iocharset=utf8 0

And I can still read/write to the mounted share

And the output of ls -la /media/UnRaid is:

drwxr-xr-x 2 root root

And still after a reboot, I can’t seem to add/set the root folder in sonarr.

I also just tried to set the root folder to ‘home’, not the mounted share and that did not work either. So it could be something else, and not related to the mount settings?

I got it!!

I checked the id of the sonar user

root@DietPi:/media/UnRaid# id sonarr
uid=104(sonarr) gid=1000(dietpi) groups=1000(dietpi)

I then set the uid and gid of the sonar user in my fstab, and then I was able to set the root path.

Well, I can’t add 3rd post to the topic being new to the forums, but…

Yeah, I’m not quite familiar with what the mount options need to be let all users be able to read/write. And I know i need to fix/change it to all all users as I have the same issue now with Radarr unable to set the root path.

I’m gonna go google/search the correct mount settings, but if you no it quickly (and for others) would be much appreciated.

You mount a SAMBA share. By default SAMBA don’t support Unix file system permission. Within your mount settings, you specify the user who will own file on SAMBA. In your case, you use uid=0,gid=0 which is root user. Therefore you see /media/UnRaid owned by user root. And root is the only one who is able to write into this folder due to your mount settings. Theoretically you could switch mount to user sonarr or allow everybody to write to this share by settings correct mount options.