Sonarr: Access to the path is denied

Hi there,

I have this baffeling access to path is denied problem.
Situation is as follows:
I have mounted two folders from my Synology NAS via Samba. Download and series. When I add a new series to Sonarr, it is able to create a new folder in series. Nzbget has no problems creating files in download.
Both folders have the same permissions:

root@mediaPi:/mnt# ls -lah
drwxrwx---  2 dietpi dietpi    0 Feb 15 00:04 download
drwxrwx---  2 dietpi dietpi    0 Feb 15 09:52 series

Both users are part of the dietpi group:

root@mediaPi:/mnt# id nzbget
uid=994(nzbget) gid=991(nzbget) groups=991(nzbget),1000(dietpi)
root@mediaPi:/mnt# id sonarr
uid=998(sonarr) gid=994(sonarr) groups=994(sonarr),1000(dietpi),1001(guest)

But sonarr still cannot post process files created by nzbget.

Couldn't import episode /mnt/download/complete/tv/CENSOREDFOLDER/fc58380c43201d814d408835d5fbffa4.mkv: Access to the path is denied.

At first I thought it might be a umask problem. I tried 0000, 0002, 1000 settings in nzbget and it didn’t make a difference.

I tried to chmod 777 but thats not working.

I have no idea what to try next. If somone has an idea I would be greatful.

Alright right after posting I had one last idea and it WORKED.

I unmounted all my NAS drives and remounted them using NFS. This allowed me to chmod 777 them and chown dietpi:dietpi them. Suddenly everything works.
I still have no idea why samba cifs did not work. But NFS at least does so I am happy.

Hope this might help somone.

Complete noob here, I don’t suppose you could provide the code you used to get this working, I seem to be having the same issue and tried everything.


best to my knowledge this is a known issue of Sonarr v2 using Mono v6 not being able to write to CIFS mounts

As well a point on the known issue section of the release notes