[Solved] XU4 Upgrade to 8.4.2 hangs

Hi,

yesterday I started the upgrade to 8.4.2 on my XU4. It hangs at:

 DietPi-Update
─────────────────────────────────────────────────────
 Phase: Installing new DietPi code

[  OK  ] DietPi-Update | Downloading update archive
[  OK  ] DietPi-Update | Unpacking update archive
[  OK  ] DietPi-Update | Removing unused files
[  OK  ] DietPi-Update | Hardening update archive mode
[  OK  ] DietPi-Update | Installing new DietPi scripts
[  OK  ] DietPi-Update | Installing new DietPi system files
[ SUB1 ] DietPi-Set_software > verify_dietpi.txt
[  OK  ] DietPi-Set_software | Downloading current dietpi.txt
[  OK  ] verify_dietpi.txt  | Completed

I killed the process and restarted the upgrade, but it keeps hanging at the same stage.
Any ideas what could be wrong?

EDIT:
Solution: reboot.
But before, I checked what could be the problem. With

ps axf

I saw the subprocess

sync

of dietpi-update. So I tried to run

sync

after killing dietpi-update, and had the same problem.
Since reboot, I can happily sync and dietpi-update finished.

Thanks
rncwnd

sync syncs data from the filesystem cache onto the disk. If much data was hold in cache and the SD card (?) is slow, this can take a while. Please do not kill (at least not SIGKILL/kill -9) this process but give it a while to finish. I’m not sure whether this can cause filesystem corruption. If one LED is configured to show disk I/O, you should see it flashing as well during sync.

Hi MichaIng,

I know what sync is for. I let it run over night. Still no progress. Then I decided to do a reboot.
The sync subprocesses could not be killed btw…

Hmm that is strange. Does dmesg report any I/O errors of interrupt timeouts?