SOLVED V6.9 update locked me out. Reset passwords?

Unfortunately I cannot login to my DietPi after updating from v6.7 to v6.8.

The installer prompted me about setting a new password, which I declined (because I already had changed my root password after setting up the system). THEN it requested me to change the password for the unix user, which I did. But now NONE of the passwords are working any more, I tried every combination of them.
Same behavior via SSH and working directly on the Pi.

Is there any way resolving this NOT requiring starting from scratch?

Can I restore my dietpi-backup without logging in? :slight_smile:

Solution for me:

  • shutdown the dietpi (has to be hooked up to a display for that, because you only can restart it using ctrl-alt-del and wait for the right moment to cut the power)
  • put the sd card in a reader
  • fire up a linux vm, mount the card
  • mv /etc/shadow- /etc/shadow

Turns out that the updater changed BOTH the dietpi and the root user’s password. But neither of them to what I entered…

Exact same thing happened to me. Most recent image, changed password, updated to the most recent packages. Reboot. Could login. Literally installed only mc from software menu, wanted a reboot. No more login on both users. Neither any default pws nor any of them that i set.

Narfel
Which password did you choose? Perhaps there is some special character expended unintentionally.

I could not do anything so I did a reinstall and used different passwords and created a 3rd sudo user for safety. No issues anymore on this front.

Great it works now. However if you remember your old password, especially some non a-z and 0-9 characters, would be great if you could provide them so I can run some tests which one might lead to the failure.