[SOLVED] sudo password request after upgrade to 6.22.3

Just upgraded to 6.22.3 on 2 hosts
host#1 - no problems, plain password ssh login if that matters
host#2 - ssh key-based auth, after entering a passphrase additional request comes up:

[sudo] password for {username}:

  • this is something new!

Pressed ^C here and noticed the following:

Waiting for DietPi-Postboot to finish… (Press CTRL+C to abort) (0)

Also running 6.22.3, on a Raspi 3B+. Happens when bash starts regardless if opened from LXterminal inside LXDE or via a tty. Also happened on my Odroid HC1 so its not just Raspi image

Hi!

Occurred on my Odroid-XU4, too.
I managed to fix it by removing the sudo before the systemctl checker loop that checks whether the dietpi-postboot is finished (ergo service status is exited or not)
That command works without sudo as well.
Just simply run the following command, and it will do the trick :slight_smile:

sudo sed -i 's%\(until \)\(sudo \)\(systemctl\)%\1\3%g' /DietPi/dietpi/dietpi-login

thanks to varaki, solved

AndrewZ varaki monery
Yeah indeed this happens when logging in with a user that has no sudo permissions without password. It even loops if there are no sudo permissions at all.

The better/best solution which I implemented for v6.23 is btw to replace the line with:

while pgrep -f '/DietPi/dietpi/postboot' &> /dev/null

“pgrep” is the simpler and faster command to do the intended check and does not require root permissions.

See: https://github.com/MichaIng/DietPi/issues/2667

thanks, MichaIng
fixed the script on 2 hosts as you suggested

worked perfectly on pi3 image. Thx bunches