[Solved] Odd update behaivor - Version 6.20.6

I used dietpi-update and updated however after reboot I am still at the older version. I can’t update from 6.19.7 to 6.20.6. Also I don’t even see any information on that particular release in the forums. Is this something bad? Any advice would be helpful.

I can get the screen that says Update applied: Current version v6.20.6 and it asked me to reboot. After reboot, I’m still notified there is an update.

Update: Well, after three reboots and two additional attempts to update it seems to have taken. I show I’m on 6.20.6. No idea what was going on but if anyone wants logs I’ll be happy to provide that. Just let me know.

Same here…
three reboots and 4 “dietpi-update” starts to get the full update…
after that some annoying questions and tasks to solve

much more interesting:
why is /etc/rc.local not working anymore? please help!

roman1528
The issue should be resolved with v6.21.

If you did already get stuck with the update, please do the following:
Cancel any dietpi-software prompt, if it opens automatically on login, then:

> /DietPi/dietpi/.update_stage
echo 1 /DietPi/dietpi/.install_stage
dietpi-update 1

About /etc/rc.local:

  • Note that this is a relict from old times that is on fresh Debian installs not enabled by default anymore.
  • DietPi just follows the Debian defaults here.
  • You should instead use a systemd unit to run certain scripts on startup. Or use a DietPi implementation by placing your script into: /var/lib/dietpi/postboot.d/
  • If you really require or want to use rc.local, enable the backwards compatibility service: systemctl enable rc-local

Thank you.
Update to 6.21.1 solved the rc.local problem…
but now, on raspberry, wifi is not working anymore.

More to that in a new thread…