[SOLVED] Kodi 19.4+no azerty keyboard

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8 G_DIETPI_VERSION_SUB=12 G_DIETPI_VERSION_RC=1 G_GITBRANCH='master' G_GITOWNER='MichaIng' G_LIVE_PATCH_STATUS[0]='applied'
  • Distro version | bullseye
  • Kernel version | Linux DietPi 5.15.76-v8+ #1597 SMP PREEMPT Fri Nov 4 12:16:41 GMT 2022 aarch64 GNU/Linux
  • SBC model | `RPi 3 Model B (aarch64)
  • Power supply used |
  • SD card used |

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

Expected behaviour

Actual behaviour

when I launch kodi in console (dietpi server), the welcome screen of kodi appears (would you like to enable this addon). But I can't confirm (yes or no) because the keyboard doesn't work anymore.

Incidentally I have other errors in the kodi log

Extra details

ERROR <general>: GetDirectory - Error getting /usr/lib/aarch64-linux-gnu/kodi/addons
ERROR <general>: GetDirectory - Error getting special://xbmcbin/addons
ERROR <general>: CAddonInfoBuilder::Generate: Unable to load '/home/dietpi/.kodi/addons/metadata.album.universal/addon.xml', Line 0
Failed to open file
ERROR <general>: CAddonInfoBuilder::Generate: Unable to load '/home/dietpi/.kodi/addons/metadata.artists.universal/addon.xml', Line 0
Failed to open file
ERROR <general>: DBus error: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
ERROR <general>: open_restricted - failed to open /dev/input/event0 (Permission denied)
ERROR <general>: open_restricted - failed to open /dev/input/event1 (Permission denied)
WARNING <general>: JSONRPC: Could not parse type "Setting.Details.SettingList"
ERROR <general>: OpenConnection - could not opening a connection to the CEC adapter

Good evening,
I’m making some progress in this mess: when I log in as root, everything goes well. When I log in as a user, everything crashes.
Do you know why?

I found ! The default ‘dietpi’ user is not part of the video group. So I added it:
sudo usermod -a -G video dietpi

Everything is all right.

1 Like

Yes, this is correct. User dietpi don’t have such rights on a default system