[SOLVED ][HC1] running Benchmarks leads to reboot

Odroid HC1 running v6.22.3, root fs moved to SSD.

Every time I run benchmark (dietpi-config - Tools - Benchmarks) system immediately reboots at this stage:

[  OK  ] DietPi-Benchmark | Running benchmark suite tests, please wait...
[  OK  ] DietPi-Benchmark | Running DietPi-CPU Benchmark with max value of 1000000 over 8 cores, please wait...
0 125000
125000 250000
250000 375000
375000 500000
500000 625000
625000 750000
750000 875000
875000 1000000
2778

Edit: seems to be solved by changing power supply. Initially it was 5V2A noname source successfully used for other projects, now it is Ugreen charger with 2.4A output.

AndrewZ
Your external SSD does not have a dedicated power supply? I highly recommend, especially with root fs on it, since a USB port is usually not made to power more than a USB flash drive, especially on SBCs.

Generally you can run dmesg to check for kernel error messages related to low voltage.

MichaIng, my SSD is attached to SATA port, not USB. This is Odroid HC1.
Anyway, power lesson is learned. Thanks!