[Solved]Download Problem: RPi version

Using Firefox 61.0.1 on Mint 19 Xfce, I get an error when trying to download the 7z file from the DietPi web page

/tmp/mozilla_paul0/qdTq+TIA.7z.part could not be saved, because the source file could not be read.
Try again later, or contact the server administrator.

Been away from DietPi for a while but long term Linux/FF user, I have never seen anything like this and it doesn’t occur with other downloads. I was able to successfully download using “wget” on the command line and the sha256sum is good. The download

wget > REMOVED OBSOLETE LINK

gave me version 6.8, not the newer version.

Hmm, maybe we can investigate server side and perhaps you via browser console, why the download fails.

About image version:
Jep, we do not update all our images with every new DietPi update, you can guess the version via modification date. But this is also not necessary, as DietPi updates itself automatically on first boot. It might feel cleaner to directly flash the most current version, but especially on clean images, the difference due to our incremental patching will be marginal or not existent.

Thanks for the reply. Yes, it did upgrade to the newest version (6.12) thank you. Not sure on this end why the download failed…even tried with plugins disabled. I also started the downloads on several other distros but had normal starts. Wget is always more dependable than the browser based download manager.

The download problem was solved by running FF in the “safe mode” which disables all extensions.