(solved) Dietpi update fails

running 8.13.2, been updating regularly for ages. Since 8.13, every release has failed with error code 139 on apt-mark manual wireless-regdb

immediately above the error is …
[ … ]/boot/dietpi/func/dietpi-globals: line 831: 1778 Segmentation fault “${acommand[@]}” &> “$fp_log”

everything I want to do using 8.13.2 works fine

help appreciated please
thank you

This is indicating some file corruption. You could try to replace the file as follow

curl -sSfL https://raw.githubusercontent.com/MichaIng/DietPi/master/dietpi/func/dietpi-globals -o /boot/dietpi/func/dietpi-globals

thanks, but no change

maybe SD Card failing ?

anything special on kernel error messages

dmesg -l 0,1,2,3
1 Like

just …
7.677239] hwmon hwmon1: Undervoltage detected!

tried a different power source and no voltage error
maybe combination of voltage and SD card failing. Anyway will move to booting from USB in future.

If you will boot from USB HDD/SSD I recommend using a powered SAT to USB adapter, otherwise you most likely will run into power issues again.

was going to try memory stick first

What SBC you are running? Unfortunately you ignored our template, therefore we don’t know.

it is a Raspberry Pi 3B+

ok on a 3B+ USB boot should be working ootb Raspberry Pi Documentation - Raspberry Pi hardware

this is peculiar, I tried restoring an old pi image to the same SD Card from a few months ago. Then went through the update process and got exactly the same segmentation fault. Is this reasonable?

Could be some issues with SD card or the corruption is already on your backup data

tried installing a backup image onto USB memory stick and got the same fault. I guess I am going to have to reinstall dietpi.

Looks like you have that corruption for long already.

OK reinstalled and setup my software. One thing I have forgotten, sorry to trouble you

I have a USB disk which I have mounted as the userdata location. It contains my php programs and data in /mnt/dietpi_userdata/www.

how do I tell Apache to look there for its root?

Ok, sorted it thanks.