[SOLVED] Dietpi-Update failed - jellyfin repo

Hi, I try a dietpi-update, it failed at apt update to fetch jellyfin repo.

E: Failed to fetch https://repo.jellyfin.org/debian/pool/main/j/jellyfin-ffmpeg/jellyfin-ffmpeg_4.3.1-2-buster_am ││ d64.deb 404 Not Found [IP: 2604:a880:cad:d0::cf3:f001 443]

Edit: it’s on x86_64 version of dietpi.

Solved with this post :
https://jellyfin.org/posts/jellyfin-apt-key/

Do with sudouser a renew of jellyfin key:

wget -O- https://repo.jellyfin.org/jellyfin_team.gpg.key | sudo apt-key add -

Hi,

this is already fixed on latest DietPi release 6.34.3

 DietPi-Software
─────────────────────────────────────────────────────
 Mode: Installing Jellyfin: FOSS web interface media streaming server

[  OK  ] DietPi-Software | Checking URL: https://repo.jellyfin.org/jellyfin_team.gpg.key
[  OK  ] DietPi-Software | eval curl -sSfL 'https://repo.jellyfin.org/jellyfin_team.gpg.key' | gpg --dearmor -o /etc/apt/trusted.gpg.d/dietpi-jellyfin.gpg --yes

Hi, thanks!
This error appear in updating from 6.33 to 6.34.
Hope it can help.

the issue is not with the DietPi update. It’s more a problem updating the jellyfin apt package. I guess similar would happen if you run apt update && apt upgrade independently