[SOLVED] DietPi-Software Error - won't install anything

Hi,

I am having a strange Issue with Wheezy v102. I wanted to try out the new Image so i flash erased my sdcard with SD Formatter and flashed the new v102 image onto it. Did the initial Setup including Language, Region, Keyboard (German) and Display Setup (1080p). Enabled the RPi Camera.

WiFi works fine. Pinged Google as a test.

Final Step was to use dietpi-software to install LASP Stack, Samba and DietPiCam.

I have done all of this a million times before. NEVER had an issue.

But this Time following error shows up and nothing is being installed. The manual apt-get method seems to work but i do want the optimizations as this is why i use DietPi in the first place.

Please check the Bugreport i sent you: 74da3804fb1b-0

Regards

Hi Zombie,

Thanks for the report. I’ll take a look into your bugreport, settings today and get back to you.
I may need to get you to test a few lines of code at some point, but i’ll let you know if thats the case.

Q: At any point prior to running the dietpi-software installation, did you manually run apt-get?

No Sir, The only things i did manually prior to dietpi-software were the above mentioned settings.

Today i re-erased my sd-card via sd formatter and repeated the entire procedure… same result. Apt-get error.

Ok, i’am looking at your bug report.

can you run the following on your system and paste result please:

ls -lha /var/cache/apt

This is the Result:

root@DietPi:~# ls -lha /var/cache/apt
insgesamt 252K
drwxr-xr-x 3 root root 4,0K Dez  3 14:45 .
drwxr-xr-x 5 root root 4,0K Apr  1  2015 ..
drwxr-xr-x 3 root root  12K Dez  3 14:44 archives
-rw-r--r-- 1 root root 264K Dez  3 14:45 pkgcache.bin
-rw-r--r-- 1 root root  37K Dez  3 14:45 srcpkgcache.bin
root@DietPi:~#

Hope it helps.

Yep, looks like apt-get update failed to finish.

Q: Are you setting up the Wifi in dietpi-config during 1st run, or, using dietpi.txt?

Can you run the following for me:

/DietPi/dietpi/dietpi-apt-get_update 2

Then paste the following:

cat /var/log/dietpi-apt-get_update

dietpi-config during 1st run. never used the dietpi.txt file. Always worked perfectly using dietpi-config.

Can you run the following for me:

/DietPi/dietpi/dietpi-apt-get_update 2

>

Did that, took about 30 seconds to finish.

> **Then paste the following:**
>
> ```text
cat /var/log/dietpi-apt-get_update

The Result:

root@DietPi:~# cat /var/log/dietpi-apt-get_update
Holen: 1 http://archive.raspberrypi.org wheezy Release.gpg [473 B]
Holen: 2 http://raspberrypi.collabora.com wheezy Release.gpg [836 B]
Holen: 3 http://mirrordirector.raspbian.org wheezy Release.gpg [490 B]
Holen: 4 http://archive.raspberrypi.org wheezy Release [17,6 kB]
Holen: 5 http://raspberrypi.collabora.com wheezy Release [7493 B]
Holen: 6 http://mirrordirector.raspbian.org wheezy Release [14,4 kB]
Holen: 7 http://raspberrypi.collabora.com wheezy/rpi armhf Packages [2214 B]
Holen: 8 http://archive.raspberrypi.org wheezy/main armhf Packages [135 kB]
Holen: 9 http://mirrordirector.raspbian.org wheezy/main armhf Packages [9557 kB]
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-de_AT
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-de
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en
Ign http://archive.raspberrypi.org wheezy/main Translation-de_AT
Ign http://archive.raspberrypi.org wheezy/main Translation-de
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Holen: 10 http://mirrordirector.raspbian.org wheezy/contrib armhf Packages [26,4 kB]
Holen: 11 http://mirrordirector.raspbian.org wheezy/non-free armhf Packages [58,0 kB]
Holen: 12 http://mirrordirector.raspbian.org wheezy/rpi armhf Packages [511 B]
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-de_AT
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-de
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-de_AT
Ign http://mirrordirector.raspbian.org wheezy/main Translation-de
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-de_AT
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-de
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-de_AT
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-de
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
Es wurden 9820 kB in 18 s geholt (541 kB/s).
Paketlisten werden gelesen...
root@DietPi:~#

Cache looks different now:

root@DietPi:~# ls -lha /var/cache/apt
insgesamt 35M
drwxr-xr-x 3 root root 4,0K Dez  5 15:04 .
drwxr-xr-x 5 root root 4,0K Apr  1  2015 ..
drwxr-xr-x 3 root root  12K Dez  3 14:44 archives
-rw-r--r-- 1 root root  18M Dez  5 15:04 pkgcache.bin
-rw-r--r-- 1 root root  18M Dez  5 15:04 srcpkgcache.bin

Thanks.

I’ve made some changes to dietpi-software that will simulate an apt-get install, before attempting to run the installation. It will also attempt to resolve an unfinished/broken apt-cache.

I would be grateful if you could test this on your system. Please do the following:

  • Write a new DietPi v102 image
  • Before powering on the device, extract the attached file to /boot/dietpi/dietpi-software replacing the existing.
  • Power on system, and go through your setup process as normal. Let me know the results.
    dietpi-software.zip (32.3 KB)

Hi FourDee,

It works!! :smiley:

Flash erased the SD Card via SD Formatter
Flashed v102 with W32 Disk Imager
Replaced dietpi-software with the one from your previous post.

DietPi then went through the Setup like a Boss. Installed LASP Stack and Samba as a Test. No Errors. No broken Cache. No Problems :wink:

I will mark this topic as solved. Please merge this new dietpi-software File in v103.

Thank You for your help. You are my hero of the day :smiley:

Regards

Awesome, great to hear its working, and thanks for testing.

I have updated the dietpi-software code with this fix, and, it will be available in DietPi v103: https://github.com/Fourdee/DietPi/issues/132.