[Solved]Certbot Illegal instruction

Hello everyone, I want to say that I am very impressed with DietPi and how it automates a lot of boring tasks.

Unfortunately, I am having a little problem with certbot, I am not being able to use it properly. When I run
dietpi-letsencrypt, after doing Apply i get the following error,

[  OK  ] DietPi-LetsEncrypt | Nginx webserver detected
[  OK  ] DietPi-LetsEncrypt | Desired setting in /etc/nginx/sites-available/default was already set: 	server_name electronic4fun.com;
/DietPi/dietpi/dietpi-letsencrypt: line 54:  6498 Illegal instruction     $FP_BINARY $options --agree-tos --rsa-key-size "$LETSENCRYPT_KEYSIZE" -m "$LETSENCRYPT_EMAIL" -d "$LETSENCRYPT_DOMAIN"
[FAILURE] CertBot failed with error code (132), please check it's terminal output. Aborting...

May someone help me to understand this problem?

Thank you

Many thanks for your report.
The line 54 should be a totally different one, not sure if the script might be somehow wrong/corrupted.

Since v6.23 was just released, could you update first and retry then?

If it still does not work, please try to run CertBot manually:

certbot --nginx

Thank you for replying MichaIng.

I followed your advice and updated the system to v6.24. Unfortunately, this didn’t solve the problem.
Run manually CertBot produced the same output.

After searching a little bit I found that CertBot depends on some libraries that are not compatible with Armv6. I own a Raspberry Pi B+, so that may be the problem. I think there are already solutions for this problem, but right now I don’t have much free time. I hope next week to be able to solve this.

EDITED: I was trying to follow this guide,


Supposedly the error is due to the library libaugeas being compiled to Armv7 instead of Armv6, but I don’t have it installed. So the problem is somewhere else.

EDITED2: Problem solved just don’t know why. I decided to uninstall certbot and install again. During the way DietPi upgraded a couple of packages, (i don’t know if it’s relevant), and now everything works just fine. Once again, congratulations on this Linux distribution.

I just wanted to say… Since the CertBot package is coming from Raspbian repo, it is definitely (+ all dependencies) ARMv6 compatible. Otherwise it would refuse to install in the first place. Not sure where the initial error came from then, but glad you solved it :slight_smile:.