[SOLVED] Cannot login to DietPi Dashboard

I just installed DietPi dashboard. I can connect to it remote, but it doesn’t accept my software password (to be certain I changed this to a very simple one and rebooted), account password or the default “dietpi”.

How to fix?

OK, after accidentally rebooting my remote PC the Dashboard responds - but now it asks no passwords whatsoever?!? Didn’t request one on FireFox, my main browser, or Brave which I didn’t use before connecting, or Chromium…

I’m liking DietPi so far, within 24 hours become my go-to RasPi OS (heck I’m even replacing the OS in my RasPi 4 :smiley: ) but these little stumbles I’ve had… can’t say troubleshooting is extremely intuitive.

ok what eaxtly is the issue now? Your password is not accepted or it’s not asking a password at all?

Issue changed. When I wrote that, it didn’t accept my password and wouldn’t let me in. Now it doesn’t ask for one in the first place.

can you check Password protection settings within /opt/dietpi-dashboard/config.toml

# Password protection
# - Default: false
pass = true
# To get hash: "echo -n '<PASSWORD>' | sha512sum"
hash = "5b586e333ab6ffdc173d3fd597b6d9bf3941d84cbf4e1578d7b28fcd514a83fb7c979e880759a4106dc640021e6e81129bab528b0d9f27ea1746790a8c550d2f"
# To get random secret: "openssl rand -hex 32"
secret = "6718995afa9d2f970e565a0da06324b2c789ff72c0c6fe8fa8489f331e68b226"
# Token expiry time in seconds
# - Default: 3600
#expiry = 3600

OK, I closed the Dashboard on my remote PC, reopened it by browsing to http://:5252 and I’m back to square 1. Dashboard asks for password, but doesn’t accept the configured SW password, my user password or root password.

I changed the SW password in DietPi-Config to asdf, restarted dietpi-dashboard.service:

root@holvi:/home/pg# dietpi-config 
[ SUB1 ] DietPi-Set_software > passwords
[  OK  ] DietPi-Set_software | chown root:root /var/lib/dietpi/dietpi-software/.GLOBAL_PW.bin
[  OK  ] DietPi-Set_software | chmod 0600 /var/lib/dietpi/dietpi-software/.GLOBAL_PW.bin
[ INFO ] DietPi-Set_software | Global software password successfully changed
[  OK  ] passwords  | Completed
root@holvi:/home/pg# systemctl restart dietpi-dashboard.service

Cleared Brave browsing data from past 24 hours and tried again. Password not accepted.

Changing the password on DietPi configuration will have no effect to the Dashboard. We will set the password only onces during install. Afterwards you need to set it within Dashboard configuration file.

Just update the hash as described.

Ah. OK, thanks. I missed that here. Apparently I need new glasses. And moar coffee :stuck_out_tongue_winking_eye:

Anyhoo, great OS; fits like a glove for a #! fanatic - once I learn the little quirks :slight_smile:

Always good to have a look to our online docs System Statistics and Management Options - DietPi.com Docs

Quoting ex-colleague “We’re engineers, we don’t read manuals” :laughing: