# Services have stopped

**URL:** https://dietpi.com/forum/t/services-have-stopped/16238
**Category:** General Discussion
**Created:** [14 March 2023 23:22 UTC](https://dietpi.com/forum/t/services-have-stopped/16238 "2023-03-14T23:22:05Z")
**Posts on this page:** 18
**Page:** 1

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [14 March 2023 23:22 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/1 "2023-03-14T23:22:05Z")

</div>

good night everyone, guys I need a little help, currently 2 services have stopped working, below the logs

```auto
 nmbd.service - Samba NMB Daemon
│ Loaded: loaded (/lib/systemd/system/nmbd.service; disabled; vendor
│ preset: enabled)
│ Active: failed (Result: exit-code) since Sat 2023-03-11 21:07:03 GMT; 1
│ day 14h ago
│ Docs: man:nmbd(8)
│ man:samba(7)
│ man:smb.conf(5)
│ Process: 1059 ExecStart=/usr/sbin/nmbd --foreground --no-process-group
│ $NMBDOPTIONS (code=exited, status=1/FAILURE)
│ Main PID: 1059 (code=exited, status=1/FAILURE)
│ CPU: 182ms
│
│ Mar 11 21:07:02 DietPi systemd[1]: Starting Samba NMB Daemon...
│ Mar 11 21:07:03 DietPi nmbd[1059]: invalid permissions on directory
│ '/var/log/samba/cores': has 0777 should be 0700
│ Mar 11 21:07:03 DietPi nmbd[1059]: Failed to create /var/log/samba/cores for
│ user 0 with mode 0700

```

```auto
 ● smbd.service - Samba SMB Daemon │
│ Loaded: loaded (/lib/systemd/system/smbd.service; disabled; vendor │
│ preset: enabled) │
│ Active: failed (Result: exit-code) since Sat 2023-03-11 21:07:03 GMT; 1 │
│ day 14h ago │
│ Docs: man:smbd(8) │
│ man:samba(7) │
│ man:smb.conf(5) │
│ Main PID: 1063 (code=exited, status=1/FAILURE) │
│ CPU: 183ms │
│ │
│ Mar 11 21:07:03 DietPi systemd[1]: Starting Samba SMB Daemon... │
│ Mar 11 21:07:03 DietPi systemd[1]: smbd.service: Main process exited, │
│ code=exited, status=1/FAILURE │
│ Mar 11 21:07:03 DietPi systemd[1]: smbd.service: Failed with result │
│ 'exit-code'. │
│ Mar 11 21:07:03 DietPi systemd[1]: Failed to start Samba SMB Daemon. │
│

```

---

<div class="post-metadata">

### Author: ![WarHawk](https://dietpi.com/forum/user_avatar/dietpi.com/warhawk/32/21_2.png) [@WarHawk](https://dietpi.com/forum/u/WarHawk)
#### Post date: [15 March 2023 03:21 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/2 "2023-03-15T03:21:49Z")

</div>

> [@negubill](#):
>
> ‘/var/log/samba/cores’: has 0777 should be 0700

‘/var/log/samba/cores’: has 0777 should be 0700

Create that directory in /var/log/samba/cores chown it to root:root and then chmod to 700  
If it is there…make sure ownership and permissions are correct

If NMBD can’t start SMBD fails also

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [15 March 2023 08:40 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/3 "2023-03-15T08:40:07Z")

</div>

You could reboot your system and check the whole log to get some more information

```auto
journalctl -u nmbd
journalctl -u smbd

```

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [15 March 2023 15:33 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/4 "2023-03-15T15:33:52Z")

</div>

> [@WarHawk](#):
>
> /var/log/samba/cores

Sorry, I understand very little, could you give me the written code so I can paste it via ssh, to create the directory with code 0700

/var/log/samba/colors

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [15 March 2023 16:06 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/5 "2023-03-15T16:06:46Z")

</div>

> [@WarHawk](#):
>
> /var/log/samba/cores

/var/log/samba/cores 0700

this way

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [15 March 2023 16:24 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/6 "2023-03-15T16:24:07Z")

</div>

to change

```auto
chmod 700 -R /var/log/samba/cores
reboot

```

to check logs as it might not fix your issue. The incorret file system permission should not have such effect. Let’s see

```auto
journalctl -u nmbd
journalctl -u smbd

```

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [15 March 2023 20:47 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/7 "2023-03-15T20:47:04Z")

</div>

```auto
Journal begins at Wed 2023-03-15 20:44:31 GMT, ends at Wed 2023-03-15 20:45:35 GMT. --
Mar 15 20:44:39 DietPi systemd[1]: Starting Samba NMB Daemon...
Mar 15 20:44:40 DietPi nmbd[818]: invalid permissions on directory '/var/log/samba/cores': has 0777 should be 0700
Mar 15 20:44:40 DietPi nmbd[818]: Failed to create /var/log/samba/cores for user 0 with mode 0700
Mar 15 20:44:40 DietPi nmbd[818]: Unable to setup corepath for nmbd: File exists
Mar 15 20:44:40 DietPi systemd[1]: nmbd.service: Main process exited, code=exited, status=1/FAILURE
Mar 15 20:44:40 DietPi systemd[1]: nmbd.service: Failed with result 'exit-code'.
Mar 15 20:44:40 DietPi systemd[1]: Failed to start Samba NMB Daemon.
Mar 15 20:45:32 DietPi systemd[1]: Starting Samba NMB Daemon...
Mar 15 20:45:32 DietPi nmbd[1890]: invalid permissions on directory '/var/log/samba/cores': has 0777 should be 0700
Mar 15 20:45:32 DietPi nmbd[1890]: Failed to create /var/log/samba/cores for user 0 with mode 0700
Mar 15 20:45:32 DietPi nmbd[1890]: Unable to setup corepath for nmbd: File exists
Mar 15 20:45:32 DietPi systemd[1]: nmbd.service: Main process exited, code=exited, status=1/FAILURE
Mar 15 20:45:32 DietPi systemd[1]: nmbd.service: Failed with result 'exit-code'.
Mar 15 20:45:32 DietPi systemd[1]: Failed to start Samba NMB Daemon.

```

```auto
-- Journal begins at Wed 2023-03-15 20:44:31 GMT, ends at Wed 2023-03-15 20:45:35 GMT. --
Mar 15 20:44:40 DietPi systemd[1]: Starting Samba SMB Daemon...
Mar 15 20:44:40 DietPi systemd[1]: smbd.service: Main process exited, code=exited, status=1/FAILURE
Mar 15 20:44:40 DietPi systemd[1]: smbd.service: Failed with result 'exit-code'.
Mar 15 20:44:40 DietPi systemd[1]: Failed to start Samba SMB Daemon.
root@DietPi:~#

```

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [16 March 2023 01:14 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/8 "2023-03-16T01:14:09Z")

</div>

AHH my fault. There was an incorrect command above. Correct above. Please try following

```auto
chmod 700 -R /var/log/samba/cores
reboot

```

```auto
journalctl -u nmbd
journalctl -u smbd

```

---

<div class="post-metadata">

### Author: ![WarHawk](https://dietpi.com/forum/user_avatar/dietpi.com/warhawk/32/21_2.png) [@WarHawk](https://dietpi.com/forum/u/WarHawk)
#### Post date: [16 March 2023 03:44 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/9 "2023-03-16T03:44:38Z")

</div>

make sure you run that chmod command as sudo

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [16 March 2023 16:51 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/10 "2023-03-16T16:51:40Z")

</div>

```auto
root@DietPi:~# journalctl -u nmbd
-- Journal begins at Thu 2023-03-16 16:50:25 GMT, ends at Thu 2023-03-16 16:50:54 GMT. --
Mar 16 16:50:32 DietPi systemd[1]: Starting Samba NMB Daemon...
Mar 16 16:50:33 DietPi systemd[1]: nmbd.service: Main process exited, code=exited, status=1/FAILURE
Mar 16 16:50:33 DietPi systemd[1]: nmbd.service: Failed with result 'exit-code'.
Mar 16 16:50:33 DietPi systemd[1]: Failed to start Samba NMB Daemon.

```

```auto
root@DietPi:~# journalctl -u smbd
-- Journal begins at Thu 2023-03-16 16:50:25 GMT, ends at Thu 2023-03-16 16:50:54 GMT. --
Mar 16 16:50:33 DietPi systemd[1]: Starting Samba SMB Daemon...
Mar 16 16:50:33 DietPi systemd[1]: smbd.service: Main process exited, code=exited, status=1/FAILURE
Mar 16 16:50:33 DietPi systemd[1]: smbd.service: Failed with result 'exit-code'.
Mar 16 16:50:33 DietPi systemd[1]: Failed to start Samba SMB Daemon.
root@DietPi:~#

```

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [16 March 2023 17:25 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/11 "2023-03-16T17:25:43Z")

</div>

hmm it simply fails without letting us know why. Let’s start the process manually

```auto
systemctl stop nmbd.service
/usr/sbin/nmbd --foreground --no-process-group

```

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [17 March 2023 10:45 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/12 "2023-03-17T10:45:27Z")

</div>

I did the process, nothing changed, what’s the next step

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [17 March 2023 10:56 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/13 "2023-03-17T10:56:30Z")

</div>

you could share the output if you try to start the process manually.

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [17 March 2023 12:14 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/14 "2023-03-17T12:14:28Z")

</div>

journalctl -u nmbd  
journalctl -u smbd

the output would be this same code

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [17 March 2023 12:25 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/15 "2023-03-17T12:25:45Z")

</div>

this one I’m referring to [Services have stopped - #11 by Joulinar](https://dietpi.com/forum/t/services-have-stopped/16238/11)

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [17 March 2023 17:38 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/16 "2023-03-17T17:38:23Z")

</div>

I’m going to do a new dietpi installation from scratch

---

<div class="post-metadata">

### Author: ![negubill](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/n/b9e5f3/32.png) [@negubill](https://dietpi.com/forum/u/negubill)
#### Post date: [20 March 2023 13:49 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/17 "2023-03-20T13:49:46Z")

</div>

good morning, I did the dietpi from scratch, now new inactive services have appeared

```auto
 dietpi-vpn.service - VPN Client (DietPi)
│ Loaded: loaded (/etc/systemd/system/dietpi-vpn.service; disabled;
│ vendor preset: enabled)
│ Drop-In: /etc/systemd/system/dietpi-vpn.service.d
│ └─dietpi-services_edit.conf
│ Active: failed (Result: exit-code) since Mon 2023-03-20 13:49:34 GMT;
│ 2s ago
│ Process: 1810 ExecStart=/usr/sbin/openvpn --suppress-timestamps --nobind
│ --config /etc/openvpn/client.ovpn (code=exited, status=203/EXEC)
│ Main PID: 1810 (code=exited, status=203/EXEC)
│ CPU: 28ms
│
│ Mar 20 13:49:34 DietPi systemd[1]: Starting VPN Client (DietPi)...
│ Mar 20 13:49:34 DietPi systemd[1810]: dietpi-vpn.service: Failed to locate
│ executable /usr/sbin/openvpn: No such file or directory
│ Mar 20 13:49:34 DietPi systemd[1810]: dietpi-vpn.service: Failed at step
│ EXEC spawning /usr/sbin/openvpn: No such file or directory
│ Mar 20 13:49:34 DietPi systemd[1]: dietpi-vpn.service: Main process exited,
│

```

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [20 March 2023 14:04 UTC](https://dietpi.com/forum/t/services-have-stopped/16238/18 "2023-03-20T14:04:00Z")

</div>

the service is inactive by default and will only become active if you configure the VPN client using `dietpi-vpn`
