# Sending mails, ssl handshake error "wrong version number"

**URL:** https://dietpi.com/forum/t/sending-mails-ssl-handshake-error-wrong-version-number/20671
**Category:** Troubleshooting
**Created:** [6 July 2024 14:28 UTC](https://dietpi.com/forum/t/sending-mails-ssl-handshake-error-wrong-version-number/20671 "2024-07-06T14:28:20Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![huidbui25](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/h/85f322/32.png) [@huidbui25](https://dietpi.com/forum/u/huidbui25)
#### Post date: [6 July 2024 14:28 UTC](https://dietpi.com/forum/t/sending-mails-ssl-handshake-error-wrong-version-number/20671/1 "2024-07-06T14:28:21Z")

</div>

### Creating a bug report/issue

I have searched the existing open and closed issues

#### Required Information

- DietPi version 9.5.1
- Distro version bookworm
- Kernel version Linux DietPi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux
- Architecture arm64
- SBC model RPi 3 Model B (aarch64)

#### Additional Information (if applicable)

- Software title DMA (Dragon Mail Agent)

#### Actual behaviour

I installed DietPi from scratch and a few dietpi-software titles. Afterwards I manually installed DMA (dragon mail agent) using `apt install dma` for mail sending purposes. During that `dpkg-recofigure dma` automatically kicked in and I provided the needed data. All fine.

After that I copied my working DMA config from another DietPi system, i.e. I copied both dma.conf and auth.conf to /etc/dma/ It’s just those two files that contain the mail configuration. Here my dma.conf:

> SMARTHOST [in-v3.mailjet.com](http://in-v3.mailjet.com)  
> PORT 587  
> SPOOLDIR /var/spool/dma  
> AUTHPATH /etc/dma/auth.conf  
> SECURETRANSFER  
> FULLBOUNCE  
> MAILNAME /etc/mailname  
> MASQUERADE [somemail@somedomain.com](mailto:somemail@somedomain.com)

But sending mails fails with a SSL handshake error, here are the log entries:

> DietPi dma[2955]: new mail from user=root uid=8 envelope\_from=[something@mymail.com](mailto:something@mymail.com)  
> DietPi dma[2955]: mail to=[something@mymail.com](mailto:something@mymail.com) queued as 21799.55ac8e3c40  
> DietPi dma[2956]: [something@mymail.com](mailto:something@mymail.com) trying delivery  
> DietPi dma[2956]: using smarthost ([in-v3.mailjet.com:587](http://in-v3.mailjet.com:587))  
> DietPi dma[2956]: trying remote delivery to [in-v3.mailjet.com](http://in-v3.mailjet.com) [104.199.96.85] pref 0  
> **DietPi dma[2956]: remote delivery deferred: SSL handshake failed fatally: error:0A00010B:SSL routines::wrong version number**

I don’t assume DMA is the culprit - the same mail config works on another system -, but rather the victim of some SSL certificate or SSL config problem of the newly intalled DietPi. What can I do to solve that issue?

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [6 July 2024 15:07 UTC](https://dietpi.com/forum/t/sending-mails-ssl-handshake-error-wrong-version-number/20671/2 "2024-07-06T15:07:10Z")

</div>

Dietpi themselves don’t have any SSL configuration by default. Whatever you require, it would need to be configured/installed. Maybe some app configuration needed.

---

<div class="post-metadata">

### Author: ![system](https://dietpi.com/forum/uploads/default/original/1X/7e1021de2213860bce185915ce2c1786e56490ec.png) [@system](https://dietpi.com/forum/u/system)
#### Post date: [1 January 2025 03:07 UTC](https://dietpi.com/forum/t/sending-mails-ssl-handshake-error-wrong-version-number/20671/3 "2025-01-01T03:07:23Z")

</div>

This topic was automatically closed 178 days after the last reply. New replies are no longer allowed.
