Screen black when booting

Creating a bug report/issue

Required Information

I cannot access the machine yet for more information.

Steps to reproduce

I just downloaded the image (DietPi_RPi-ARMv8-Bookworm),
wrote it to the SD card and started the RPi4 with the screen connected.

Expected behaviour

I should see the console of the RPi booting up.

Actual behaviour

I see the HDMI announcing a signal of 640x480 but the screen stays black.
After a while I get vertical color stripes.
That’s it.

Extra

I also tried to set

hdmi_safe=1

but I am not sure how often the config.txt will be read.
It did not make a difference when I changed it.

I am a little stumped.
I did not have such problems before.
I will report back once I find another monitor.

What I can say is that with Ubuntu it worked just fine.

Any guidance on how to debug this?

With Raspberry OS and Ubuntu they go for 1920x1080 immediately as resolution (instead of 640x480).
I don’t see any console messages. Not sure if they are just hiding them.
But after a while the desktops come up just fine.

I managed to install dietpi with another monitor (let’s call it B).

When I boot with B and quickly switch the original monitor A, I do see the framebuffer and then the desktop. Just not in the full resolution.

Is the detection from?
Do I need to force a resolution somehow?

And when I try to switch the resolution in LXDE, it only lists the one resolution 1280x720 while it should also offer 1920x1200 (and other really).

$ xrandr -d :0
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 720, current 1280 x 720, maximum 1280 x 720
default connected 1280x720+0+0 0mm x 0mm
   1280x720       0.00*

What am I missing?

did you tried to change resolution using dietpi-config??

Now that I have access…

DietPi version

cat /boot/dietpi/.version
G_DIETPI_VERSION_CORE=8
G_DIETPI_VERSION_SUB=23
G_DIETPI_VERSION_RC=3
G_GITBRANCH='master'
G_GITOWNER='MichaIng'
G_LIVE_PATCH_STATUS[0]='applied'
G_LIVE_PATCH_STATUS[1]='applied'

Distro version

echo $G_DISTRO_NAME $G_RASPBIAN
bookworm 0

Kernel version

uname -a
Linux cnc 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux

Architecture

dpkg --print-architecture
arm64

SBC model

echo $G_HW_MODEL_NAME
RPi 4 Model B (aarch64)

Power supply used

5V 3A

SD card used

SanDisk Extreme

Interesting.

I just set it to vc4-fkms-v3d and that seems to have magically fixed everything.
dietpi-config didn’t offer the resolution I wanted but that didn’t seem to matter.

X is now running in 1920x1200 and xrandr suddenly reports:

xrandr -d :0
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 7680 x 7680
HDMI-1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1200     60.00*+
   1920x1080     60.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.90  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x480       60.00    59.94  
   640x480       60.00    59.94  

What did this change?

Could I have fixed right before the install somehow?

Thank you so much for that pointer.

Running dietpi-config before installation of a desktop or adding dtoverlay=vc4-fkms-v3d into /boot/config.txt before first boot should do same.