SAT Issues with external HDD

Hey folks,
I connected an external HDD (Seagate Desktop Expansion) to my Raspi4 (using latest and up to dte dietpi version) to use it as Nextcloud data storage.
Generally everything works fine so far. The only thing is that I want to spin the drive down or let it go to hibernate state or something to turn it off when it is not used actively. So I wanted to set the spindowntime with hdparm and I get following message when using hdparm.

With lsusb -t I found out that it is an UAS partition

And now I found this guide https://www.smartmontools.org/wiki/SAT-with-UAS-Linux.
Summarized it tells to change the usb-storage.quirks to ignore setting the flag that SAT is not supported.
It then says to update the distrobutions ramdisk.
I did with update-initramfs -u (after and before taht I tried to create one with update-initramfs -c -k ‘all’).
Unfortunately I get same result as shown above when using hdparm.
I do not know if there is an issue as I told my SDcard to use my USB stick for /root (change that in /boot/cmdline.txt).
Can you guide me how to enable SAT commands or other ways to spindown my HDD when idle?!.
Thank you very much.

Edit: smartmon show following information

Hey folks,
found it out. You have to edit the cmdline.txt within /boot/.
usb-storage.quirks=aaaa:bbbb:u where aaaaa is the vendor id and bbbb is the device id.
update-initramfs -u → reboot → check.
Thats it.

Hi,

many thanks for sharing your solution. Much appreciated.

You are welcome.
I hate it myself, when I find the same or at least a likely problem and someone only posts → “Found solution. Thread can be closed”… :roll_eyes: