Samba Client Issues [SOLVED]


I’ve been running DietPi for awhile with no issues. Recently, I think after I updated to version 6.6 (I think?) my Plex server is having issues connecting to the Samba client which has all my media files on it. I verified I can access them on my PC so I know they’re not dead. How would I go about troubleshooting this? I don’t see any errors when I go to add in the info for it (which hasn’t changed and it was working previously) is there a way I can see the error that is causing it not to connect?

I tried uninstalling the samba client > Rebooting > Reinstalling and it still won’t connect. In dietpi-config under NAS it says Samba Client: Unable to connect and/or incorrect details, which I know it’s not the incorrect details.

Thank you.


out of concern, which device have you running the samba client please? RPi? Odroid?

Samba server with your files, is running on what? RPi, OpenWRT, Fritzbox, Router, FreeNAS, Synologie NAS, Windows 2013 Server …?

Please have a look:

Don’t think it is a problem with DietPi updates. More with updating baseline distro, which is now automated running before dietpi-update since v6.3 DietPi/CHANGELOG.txt at master · Fourdee/DietPi · GitHub

Think you will have a newer samba version running now, installed by apt-get update and your server a outdated version.

Sorry, this is a Raspberry PI 3. My Nas is a MyCloud Duo. I typically connect using the IP ( in my case) followed by the share name and then log in credentials.

This was all working fine previously so I’m not sure what happened. I don’t typically do anything else on here except occasionally check for DietPi updates.

I just set up a new install of DietPi and installed Plex and Samba Client. The same issue is still there. It won’t connect to my NAS. I have another raspberry pi but hasn’t been updated to the latest version of DietPi and that currently has no issues Logging in to the same NAS with the same log in info.

Thanks for the links, I was able to follow one of the sub links in a thread that said to add vers=1.0 to my samba share. Thanks again.