SAMBA Access probs!

I have set up a share folder from my RPI , its accessable from min Windows computer.
But the problem is when i try to access it with mt Android phone, i can connect to the samba and i
can se the folder but i cant open it! It used to work , anyone know what to do ?

No one is going to be able to help without seeing a copy of your SAMBA settings dude.

workgroup = WORKGROUP
server string = %h server
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog only = no
syslog = 0

panic action = /usr/share/samba/panic-action %d

security = user
encrypt passwords = true
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes

passwd program = /usr/bin/passwd %u
passwd chat = Enter\snew\s\spassword:* %n\n Retype\snew\s\spassword:* %n\n password\supdated\ssuccessfully .
pam password change = yes
map to guest = bad user

load printers = no
printcap name = /dev/null
disable spoolss = yes

comment = DietPi Share
path = /xxxxxx/xxxx/xxx (obv something else)
browseable = yes
create mask = 0775
directory mask = 0775
valid users = root
guest ok = yes
writeable = yes
max connections = 8

Hmm long as you connect from your Android with user root and matching password, in case adjust with smbpasswd, then it should work. Not sure about the guest setting, probably currently the Android is connecting as guest with limited permissions?

hmm, same issue here.
is important smb version 1,2,3?

Good question, I cannot derive it from the package info:
However all moreless current clients should support version 3 and the server as well. Not sure if its fully backwards compatible until version 1.

Are you guys getting some logs on server and/or client?

/var/log/samba/%m.logs are empty … size 0 :cry: no help there
is to force:
min protocol = SMB2
max protocol = SMB2
good idea?

From the server, to be max compatible, no protocol version ranges should be defined, AFAIK.

Does journalctl -r (system log) give any hint, right after a connection attempt?