SABnzbd install stuck on generating initial config on RPi4B and VirtualBox

Hi there

I tried doing an automated installation of DietPi on Raspberry Pi 4 model b and put SABnzbd on the dietpi text file boot partition for a fresh install.

DietPi boots and does it’s initial installation and starts downloading and installing the required files for SABnzbd, but it gets stuck on the message “Generating initial config, please wait…” when configuring SABnzbd.

I’ve waited for 30mins before testing VirtualBox DietPi image and tried installing SABnzbd, but it also get stuck at “Generating initial config, please wait…”.

Does the config take a long time to generate?

Thanks

Hi,

many thanks for your request. Currently there are some issues around SABnzbd installation and it get stuck. With the upcoming release 6.32, SABnzbd will be migrated to a Python3 setup as current version still depends on Python2. I tested it already on DietPi BETA version and there it is working again. :wink:

https://github.com/MichaIng/DietPi/issues/3738

Thanks for letting me know.

I’ll hold off from installing SABnzbd until DietPi 6.32 gets released.

Much appreciated for the help.

as well you could try our beta version 6.32.1 to check if SABnzbd installation is working for your. feedback would be appreciated :wink:

https://github.com/MichaIng/DietPi/issues/3743

And you could easily switch back to original version if your create a dietpi-backup before :slight_smile:

Hi

Just to report that I updated dietpie to the beta version and reinstalled SABnzbd and it got through the installation and showing the web interface. Seems to be working so far.

Thanks :smiley:

ok you could revert back to master brach as DietPi v6.32.2 was officially released now.