Rutorrent default password change

Hello, i just installed your awesome rTorrent/rutorrent script and i want to change default rutorrent password. Tried to google it before asking here, but without luck. So how i can change password? :wink:

Access web interface:
url = http://192.168.0.100/rutorrent
username = root
password = dietpi

Hi,

As the password is applied to the webserver, it depends on the webserver stack used.

If you use the default webserver choice (lighttpd), you can change the ruTorrent password by running:
Change the password dietpi below as needed.

echo -e "root:rtorrent:$(echo -n "root:rtorrent:dietpi" | md5sum | cut -b -32)" > /etc/.rutorrent-htaccess

Then restart the webserver with:

dietpi-services restart

If your using a different webserver, let me know which and i’ll take a look.

IT WORKED! Sorry i forgot to mention that i use lighttpd. When i enter just my LAN IP address into URL bar it opens this page. Is it safe to leave like this? I dont plan making any websites public. :sunglasses:

Yep this is default webpage that gets installed, its a placeholder for your website. If you have enabled port forwarding 80 on your router to the DietPi system, anyone can access this page as read-only. In other words, they can view it as you see it and thats it.

Your ruTorrent will still be password protected. Regardless of router forwarding of port 80.

Can i somehow just disable that page and make not discoverable?

Unless you have forwarded port 80 to the IP address of your device it won’t be publicly accessible.

My port 80 is open. Is it possible to disable that page forever? I only want to keep rutorrent access.



rm /var/www/index.htm*

Now if i enter in URL: http://192.168.1.19x/ But it still says: 404 - Not Found.



I want to make that LAN IP page to say: This site can’t be reached

192.168.1.19x took too long to respond.
Try:
Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

Just create a simple HTML page along the lines of

Your message here

and replace the placeholder index.html file with it.