RPi4 | rootFS(SSD boot) & slow updating during intial setup


So i was wondering if i’m the only one with the following issues on RPi4. First of all upgrade or rather updating process was painfully slow. I read somewhere that by disabling IPv6 can help - anyway what i did was disable IPv6 and updated/upgraded manually, after that initial installation was successful. After updating and installing DietPI on my SD card (32GB SanDisk Extreme) i was wondering maybe i can boost my performance by moving rootFS to my SSD (Samsung QVO 1TB). I tried to move it by using DietPI drive manager - during that process i formatted my SSD to ext4 which was fairly easy but after reboot i was in a bit of pickle…

Kernel panic occured…

I tried to debug that by changing PARTUUID back in cmdline.txt on my SD, but then discovered that PARTUUID value was empty. If my logic is correct then shouldn’t there be boot device (SSD in my case) PARTUUID which i can get by using blkid?


dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 rootdelay=10 root=PARTUUID= rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait console=ttyAMA0,115200


foto s delen

i get this error, when i transfer root to Ssd.

Press Control D wont work, still get Press Control D

Raspberry pi 4 4Gb

What to do ?

Some have a older version off dietpi ???

Older versions have no problem with transfer root to Ssd/Hd

Please some help