RPi3B fails to update from 6.21.1 to 6.24.1 - help please.

Hello.

I noticed that my Dietpi has an update to install. To go from 6.21.1 to 6.24.1.
When I run dietpi-update it stops after a few minutes , and offers me options to retry or edit network settings.
I do not know what to do to make it work. I have tried rebooting and re-running update but the same problem occurs.
I’m not even sure what the error message is.

I can see “ash Sum mismatch” which sounds like something that went wrong, but i dont know how to access log files.
I can post screen shots once I work out how to insert images.

If someone could step me through the process that would be awesome. Thank you.

I hope these are viewable.
pre-patch.jpg
Failed to fetch.jpg
Dietpi Error Handler.jpg

cookie
Hmm a checksum mismatch. Either the lists download was corrupted or there was a temporary issue with the repository (most likely).

Please retry manually and paste full output here in case similar errors are inside: apt-get update

Thank you for the reply.

The failed update affected my install of Sabnzbd. So I attempted a restore which did nothing to fix that.
I re-imaged the SD card with the latest download and started again from scratch, which is good practice I guess.
I did get a checksum mismatch during the initial re-install as well but it seemed to sort itself out this time.

When I reinstalled sabnzbd I noticed I got a newer version that what I had before. I suppose there is a way of updating sabnzbd without having to do what I did??

So I am all good for now thanks.