RPI-Update > 4.4.16 breaks DietPi

Updated my DietPi system with rpi-update, and it completely broke it. I cannot log on via SSH anymore.

Reverted back to 4.4.16 and everything was back to normal again.

Then I tried the latest update from today (Kernel 4.4.19) and it broke again.

DietPi Jessie with latest updates runnning on an Raspi 2. Any ideas what could cause this ?

Hi Loom,

Thanks for letting us know.

Sounds like a possible broken kernel release from RPi, or, additional config.txt/cmdline.txt options and/or modifications are required.

Check both for any other users reporting the same issue:

https://github.com/raspberrypi/linux/issues
https://github.com/raspberrypi/firmware/issues

In the mean time, I’ll make a note to test this on my RPi 2 and see if we can find out whats happening: https://github.com/Fourdee/DietPi/issues/481

Thanks for the quick reply, Fourdee.

I didn’t find any issues on github so far. But it clearly looks like anything above 4.4.16 will break DietPi. It’s definately not just 4.4.19.

Hi Loom,

Just tried running with 4.4.19 on both RPi2 and RPi3. Unable to replicate: https://github.com/Fourdee/DietPi/issues/481#issuecomment-242053178

It could be:

  • a “bad” setting in config.txt/cmdline.txt preventing boot.
  • Filesystem corruption (eg: SD/PSU)
  • Unstable overclocking

If you can send me a bug report, I can check your system settings and try to replicate it here.
Please run:

dietpi-bugreport

And reply with Reference CODE. Thanks.