Rpi unknown

Hi,

I installed V118 on new RPI3 and DietPi is reporting unknown RPI version ? I also updated firmware.

Tnx.

âââââââââââââââââââââââââââââââââââââââ
DietPi | 13:41 | Sat 28/05/16
âââââââââââââââââââââââââââââââââââââââ
V118 | Raspberry Pi Unknown
âââââââââââââââââââââââââââââââââââââââ
IP Address | 10.0.0.2
âââââââââââââââââââââââââââââââââââââââ

Hi Dimi3,

You have discovered a new RPi board revision!

Please can you run the following command and print results. This will allow us to add your device to the database:

/DietPi/dietpi/misc/rpi_boardinfo

Thanks

Hi,

No problem;

root@DietPi:~# /DietPi/dietpi/misc/rpi_boardinfo

  • RPi Board Info -
    Revision | 2a02082
    Released | Unknown
    Model | Unknown
    Memory | 0 MB
    Manufacturer | Unknown

Thanks.

Strange, a02082 is known, but for some reason the code you are receiving contains a 2 infront. Probably a new flag, have you overclocked the device at all?

Lets get the raw data for revision. If you could paste the following results, i’d be grateful:

cat /proc/cpuinfo | grep 'Revision'

Hi,

I have overclocked the board, but its the same if its not overclocked.

Here is the output;

root@DietPi:~# cat /proc/cpuinfo | grep ‘Revision’
Revision : 2a02082
root@DietPi:~#

I get the same with my PiZero V1.3.

  • RPi Board Info -
    Revision | 900093
    Released | Unknown
    Model | Unknown
    Memory | 0 MB
    Manufacturer | Unknown

This was added for v118, you’ll need to update for DietPi to correctly ID the board description.
Although, DietPi knows its a RPi 1 with 512MB RAM under the hood, so staying <v118 wont effect how DietPi optimizes for your device.

Latest image available on this website is v115 and dietpi-update does not work.

Hi RaspiHacker,

Thanks for letting us know.

Do you receive any errors on the screen when running the update?

Also, can you please paste results of:

cat /DietPi/dietpi.txt | grep 'git'

Hi Fourdee!

Have been hospitalized for two weeks, just seen Your post today.

I have tried all the other suggestions in the forums regarding update problems on the V.115, but none has worked.

dietpi-update with no or any option (1,2,3) returns the same error:

DietPi-Update:
Checking for DietPi updates, Please wait...
curl: (3) Illegal characters found in URL



cat /DietPi/dietpi.txt | grep ‘git’

returns this:

root@DietPiZero:~# cat /DietPi/dietpi.txt | grep 'git'
gitbranch=master
root@DietPiZero:~#

Sincerely
RasPiHacker

Hi RasPiHacker,

No worries, hopefully your onto a good recovery?

The inability to update is most likely the line endings in dietpi.txt being dos, instead of unix. This can occur when a user edits the file on a Windows PC with notepad/wordpad.

To resolve this, please run the folllowing commands, as per this post: https://github.com/Fourdee/DietPi/issues/390#issuecomment-228723958

sed -i $'s/\r$//' /DietPi/dietpi.txt
dietpi-update

Please let me know the results :slight_smile:

Hi again.

I had tried everything in this thread:Raspberry Pi 3 wont update, but noting worked.

sed -i $‘s/\r$//’ /DietPi/dietpi.txt

Running the above fixed it, thank You Fourdee!

Strange since I have not used anything but Putty to connect via serial cable to the Zero, and nano, once logged in, to edit files on the Zero.

Anyways:

───────────────────────────────────────
 DietPi     | 21:29 | Thu 07/07/16
 ───────────────────────────────────────
 V122       | RPi Zero (armv6l)
 ───────────────────────────────────────
 IP Address | 192.168.30.49
 ───────────────────────────────────────

It works a treat now, thank You again and keep up the good work!!

Sincerely
RasPiHaker