RPI not booting after update

Hi All,

I had dietpi 6.28.0 installed on my RPI model B v1.2. Everything was running smoothly. Even I created disk image for features in case my USB boot device fails.

But after updating the dietpi my Rpi is not booting. Only red led is coming on but no green LED. But the weired part is when I write the backed-up image on my usb drive and boot it it works nicely.

As I needed to install some software but if I install it then it will automatically update the OS. And again it stops working after update. Please help me if anyone is having any troubleshooting for this issue.

Hi,

many thanks for your message. Well, dietpi-software installations as well as dietpi-update are calling apt update && apt upgrade. This is the basic Debian package installer, going to update your system and software components. Most probably something like the kernel will be updated, causing your system to fail. To verify which packages are going to be installed, you cold run apt update && apt list --upgradable. This will give you an overview of packages pending an update. You could try to update one by one to see which package is causing the issues. :thinking:

Hi,

Thanks for the update. I was trying to install one package from dietpi software list. In the process the system automatically updated the os.

Is there a way to reverse it back or install the package without doing auto update?

Well in theory it would be possible if you are going change/exclude the respective lines within dietpi-software script

https://github.com/MichaIng/DietPi/blob/208ab64c88ce168d2b3af4205544ea66edeacaf4/dietpi/dietpi-software#L14981-L14982

But this will not fix your issue, as you just going to hide. Sooner or later you might need to update your system. Probably there are more issues you are not aware of. As well, running a system without updates is not recommended either.

Is this mean we cant use RPI 3 with dietpi any more? I even tried to install a fresh image downloaded from dietpi. Same issue. The 1st boot and installation is going fine. But after restart it just dont boot.


Is there any way to fix the or we should not use RPI 3 anymore?

I personally using RPi 1, RPi3B+ and RPi4B without issues and you are first one reporting it. Therefore it would be really helpful if you can share some error messages. Or at least the log from the update. As well you could test a plain Raspberry OS and check if it behaving same. And do you use booting from SD card or USB?

I tried both the USB and SD card. Even I got a new SD card and tried in that. But both have same result. After apt update && apt upgrade it just stops booting. Blank screen. No activity on green led. Only red LEd lit up.

Also Rasbian image installation works fine but after restart just Blank screen.

ok if even plain Raspberry OS is not working, something seems to be wrong on your board. Do you have any error messages during apt update && apt upgrade??

No error while update. once update is done it asks for a reboot. After reboot the screen goes blank and RPI dont bootup.

But if I dont update and run my old dietpi image then it just works fine. No issue.

The weired thisn is only old image works fine without any issue but if I update it or install a fresh image on my sd card then it stops booting.

if any issue with PSU or SD card then it should not work at all. :roll_eyes:

Just to be sure, you tested a native Raspberry OS 32bit image as well https://www.raspberrypi.org/downloads/raspberry-pi-os/

And there, you have same issues? If this is correct, the issue is not with DietPi as DietPi is a set of scripts on top of a Raspbian OS.

I checked as well an old RPi B and it’s working without issues on latest DietPi Beta v6.33.1

root@DietPi1:~# echo $G_DISTRO_NAME
buster
root@DietPi1:~# cat /etc/debian_version
10.6
root@DietPi1:~# cat /boot/dietpi/.version
G_DIETPI_VERSION_CORE=6
G_DIETPI_VERSION_SUB=33
G_DIETPI_VERSION_RC=1
G_GITBRANCH='beta'
G_GITOWNER='MichaIng'
root@DietPi1:~# cat /proc/device-tree/model
Raspberry Pi Model B Rev 2
root@DietPi1:~# uname -a
Linux DietPi1 5.4.51+ #1333 Mon Aug 10 16:38:02 BST 2020 armv6l GNU/Linux
root@DietPi1:~#