[RPi B] - Sonarr/Radarr/Jackett error

Hi, recieving this error when trying to install mono?

Thanks.

root@DietPi:~# cat /var/log/dietpi-software_apt.log
Setting up libnunit-core-interfaces2.6.3-cil (2.6.3+dfsg-1) ...
* Installing 1 assembly from libnunit-core-interfaces2.6.3-cil into Mono
Segmentation fault
Use of uninitialized value $_ in scalar chomp at /usr/share/cli-common/runtimes.d/mono line 275.
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 225.
Segmentation fault
E: installing Assembly /usr/lib/cli/nunit.core.interfaces-2.6.3/nunit.core.interfaces.dll failed
E: Installation of libnunit-core-interfaces2.6.3-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: error processing package libnunit-core-interfaces2.6.3-cil (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of libnunit-core2.6.3-cil:
 libnunit-core2.6.3-cil depends on libnunit-core-interfaces2.6.3-cil; however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.

dpkg: error processing package libnunit-core2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnunit-util2.6.3-cil:
 libnunit-util2.6.3-cil depends on libnunit-core-interfaces2.6.3-cil; however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.
 libnunit-util2.6.3-cil depends on libnunit-core2.6.3-cil; however:
  Package libnunit-core2.6.3-cil is not configured yet.

dpkg: error processing package libnunit-util2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnunit-console-runner2.6.3-cil:
 libnunit-console-runner2.6.3-cil depends on libnunit-core-interfaces2.6.3-cil; however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.
 libnunit-console-runner2.6.3-cil depends on libnunit-core2.6.3-cil; however:
  Package libnunit-core2.6.3-cil is not configured yet.
 libnunit-console-runner2.6.3-cil depends on libnunit-util2.6.3-cil; however:
  Package libnunit-util2.6.3-cil is not configured yet.

dpkg: error processing package libnunit-console-runner2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
Setting up libnunit-framework2.6.3-cil (2.6.3+dfsg-1) ...
* Installing 1 assembly from libnunit-framework2.6.3-cil into Mono
Segmentation fault
Use of uninitialized value $_ in scalar chomp at /usr/share/cli-common/runtimes.d/mono line 275.
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 225.
Segmentation fault
E: installing Assembly /usr/lib/cli/nunit.framework-2.6.3/nunit.framework.dll failed
E: Installation of libnunit-framework2.6.3-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: error processing package libnunit-framework2.6.3-cil (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of libnunit-mocks2.6.3-cil:
 libnunit-mocks2.6.3-cil depends on libnunit-framework2.6.3-cil; however:
  Package libnunit-framework2.6.3-cil is not configured yet.

dpkg: error processing package libnunit-mocks2.6.3-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnunit-cil-dev:
 libnunit-cil-dev depends on libnunit-console-runner2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-console-runner2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-core2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-core2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-core-interfaces2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-core-interfaces2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-framework2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-framework2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-mocks2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-mocks2.6.3-cil is not configured yet.
 libnunit-cil-dev depends on libnunit-util2.6.3-cil (= 2.6.3+dfsg-1); however:
  Package libnunit-util2.6.3-cil is not configured yet.

dpkg: error processing package libnunit-cil-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-cil-dev:
 libmono-cil-dev depends on libnunit-cil-dev (>= 2.4); however:
  Package libnunit-cil-dev is not configured yet.

dpkg: error processing package libmono-cil-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mono-devel:
 mono-devel depends on libmono-cil-dev (= 5.0.1.1-0xamarin5+debian8b1); however:
  Package libmono-cil-dev is not configured yet.

dpkg: error processing package mono-devel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libnunit-core-interfaces2.6.3-cil
 libnunit-core2.6.3-cil
 libnunit-util2.6.3-cil
 libnunit-console-runner2.6.3-cil
 libnunit-framework2.6.3-cil
 libnunit-mocks2.6.3-cil
 libnunit-cil-dev
 libmono-cil-dev
 mono-devel
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi,

Thanks for the report.

May be due to lack of ARMv6 packages in the Mono repo we use for install. I’ll try to replicate on RPi Zero.

Confirmed, we’ll try to find another source for ARMv6 packages:
https://github.com/Fourdee/DietPi/issues/1023