RPi 3 stuck in powersave

Hi all,

I run an OwnCloud install on my RPi 3 using DietPi (makes for an easy install!). I noticed that I was having issues with it, running slower than I expected after a week or so. I check the CPU and it said the the Governor is Powersave and it runs pretty much only at 600MHz.

I have gone into the dietpi-config and tried to change it but it will not change out of it and the Change CPU Governor and CPU Max Freq are empty:

 Hardware : RPi 3 Model B (armv7l)                       │
          │  ARM Temp: 54'c                                          │
          │  RAM: 996 MB | Used: 320 MB | Free: 676 MB               │
          │                                                          │
          │             Overclocking        Set Profile              │
          │             Change CPU Governor :                        │
          │             CPU Max Freq Limit  :  MHz                   │
          │             ARM Initial Turbo   : 20 seconds             │
          │             ARM Temp Limit      : 75 'c

Not sure what to try next

Hi,

Looks like the entry is missing from dietpi.txt

Ensure the following entry exists once in /DietPi/dietpi.txt

cpu_governor=ondemand

Checked and the Dietpi.txt was empty, 0 bytes - weird. Restored from backup (yay for actually doing one and DietPi making it easy!) and system is back to normal.

Cheers for help!!