RockPro64 and Dietpi 8.X fresh install: Finding (Nemo?) Drive

Hi everybody,

I wanted to share one problem that I’ve been able to solve. I think that it could help some poeple:
I had dietpi in the other Debian version.
I’ve tried to follow the way to upgrade to Bullseye and it worked.
BUT, I don’t know why mariadb service was disabled. I’ve looked for solution but I’ve found nothing that worked for me.
So, I said to myself “you know what f**k it!” and I reinstalled Dietpi.
After that the system was unabled to find my Hard Drive.

The solution was to put the following line on this file: /etc/udev/rules.d/99-marvell.rules

ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x1b4b", ATTR{device}=="0x9230", RUN+="/bin/bash -c 'echo %k > /sys/bus/pci/drivers/ahci/bind'"

I rebooted the system and TADAAA!

Here’s where I’ve found the solution:
(Maybe, it could be added on the next dietpi upgrade…)

Thx for sharing. This is quite a specific rule and might apply for your system only. Therefore I guess it will not become part of standard DietPi install :wink: