Rock 4 C+ Dietpi Support?

many thanks for your help.
will try again tonight

I use EMMC memory

good evening
I have tried everything according to your instructions
unfortunately it doesn’t help if I

apt install --reinstall systemd

perform
the 2nd option with Armbian doesn’t really work either
I didn’t try it via the SD card because I want to start it via EMMC

I’m using Debian at the moment
I have the fewest problems there and was able to finish the system config

If a new version comes out in the near future, my Rock 4 C+, I’ll try again

or maybe you have an additional solution

Armbian and DietPi as as much Debian as the Radxa Debian image :wink:. What you use and what of course is expected to work is that vendor’s (Radxa’s) kernel and bootloader, which is the key difference.

The problem is that this kernel is ancient, and has hence issues and limitations on recent Debian versions, regarding container engines and modern kernel features like WireGuard, nftables/bpfilter and more, and a set of additional problems with Bookworm, the next Debian release this summer. This is also the reason why Radxa is providing Debian Buster (EOL since last summer) images only. And as vendors usually never update their kernels for one device, it has no future.

the 2nd option with Armbian doesn’t really work either

Can you go into detail why exactly did not work, where it failed, in case error messages? This is actually supposed to work reliable, as long as the Armbian image itself boots. And you did select “22: Generic device” in the installer? Selecting “ROCK Pi 4” would break it.

It seems to work fine on SD card, btw, so indeed only eMMC support is missing with the U-Boot build: Rock4C+ no-wifi-hardware-found

Hi audizo,

I also have a Rock Pi 4c+ but didn’t experience the issues that you posted.

I used the imager, got my 64gb sd card (i did order a eMMC but it didn’t arrive in time) I will use dd to transfer to the eMMC once it arrives.

Only real issue I had is that when it first booted the logon prompt did say hit enter, but no usb keyboards were detected. SSH worked fine but I did have a few issues with apt updates but was able to solve them.

Can I ask what power supply you are using, maybe it could be related to this?

Best regards.

Q.

1 Like

Does onboard WiFi work in your case?