Retrieve Global Password?

Had my Pi up and running for a while now. Only app that asks for my global password is one I’venot used for ages.

Guess what…? I can’t remember my pasword. I can access the Pi through VNC so can dig around, but where can I find this/reset it?

Many thanks

For some application the password is applied directly into the application. Means changing them on OS level will not change it within the App. What app your are looking for? Did you tried the root user password? Sometimes it might be same :wink:

in generell you can reset the password using dietpi-config > 6 : Security Options > 1 : Change Passwords

The app in question is Transmission.

Will try the options you listed below.
Stay tuned.

Many thanks

Changed password (had to out new credentials into VNC so I know it worked and new passowrd works OK) but Transmission is having none of it (makes me thikn I asn’t getting my passwprd wromg before!)

Reinstall Transmission?

as told above, some application store the password on own config files and changing them on dietpi-config will not have any impact.

for transmission, you could do following

systemctl stop transmission-daemon.service
G_CONFIG_INJECT '"rpc-password"' '    "rpc-password": "new-password",' /etc/transmission-daemon/settings.json
systemctl start transmission-daemon.service

Oh no, that didn’t work :cry:

I testes it and for me it is working fine. You closed the browser? and used user root + password you set??

yep - robooted Pi as well

Just uninstalled Transmission, rebooted adn then tried to reinstall Transmission. It fails and I get this message:

Setting up transmission-daemon (2.94-2+deb10u2) ...
chown: invalid group: ‘debian-transmission:debian-transmission’
dpkg: error processing package transmission-daemon (--configure):
 installed transmission-daemon package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 transmission-daemon
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hmm, not sure why Transmission is being so picky :thinking:

try following

groupadd -r debian-transmission
usermod -aG debian-transmission debian-transmission
apt -f install
dietpi-software install 44

btw: what is the DietPi version you are running?

Thanks for that. It allowed me to install Transmission OK, but when I then try to access IPaddress:9091 via a browser I get this message:

403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you’re editing settings.json, see the ‘rpc-whitelist’ and ‘rpc-whitelist-enabled’ entries.

If you’re still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

DietPi version is v7.9.3

Many thanks

usually this should have been fixed already. Can you try following and post the output

dietpi-software reinstall 44

This is what I get:

 Mode: Automated reinstall

[ INFO ] DietPi-Software | 44: Transmission is not currently installed
[ INFO ] DietPi-Software | Use "dietpi-software install 44" to install Transmission.
[  OK  ] DietPi-Software | No changes applied for: Transmission

did you run dietpi-software install 44 as I indicated on the fixing post?

Yes I did. This is a copy from the Terminal window:

root@DietPi:~# groupadd -r debian-transmission
root@DietPi:~# usermod -aG debian-transmission debian-transmission
root@DietPi:~# apt -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up transmission-daemon (2.94-2+deb10u2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/transmission-daemon.service → /lib/systemd/system/transmission-daemon.service.
root@DietPi:~# dietpi-software reinstall 44
[  OK  ] DietPi-Software | Initialised database
[  OK  ] DietPi-Software | Reading database

 DietPi-Software
─────────────────────────────────────────────────────
 Mode: Automated reinstall

[ INFO ] DietPi-Software | 44: Transmission is not currently installed
[ INFO ] DietPi-Software | Use "dietpi-software install 44" to install Transmission.
[  OK  ] DietPi-Software | No changes applied for: Transmission

pls use install instead of reinstall

dietpi-software install 44

That did it. No idea why I’d put reinstall as I copied and pasted all commands.

Many thanks for your help.

Great community