[Resolved] "Removing diversion of boot/overlays/README" err

Hello, I’m trying to set up DietPi on a Raspberry Pi 2 Model B. I’m having a reoccurring issue with the installation however, that I haven’t managed to solve. After hours of searching online, I haven’t seen anyone have this issue, so I’m not sure what is the problem.

Everything works fine with the beginning of the installation, finding the USB HDD (Using a Western Digital Elements 2TB USB 2.0) and network and everything. But when I select “Go Start Install” and it does its thing, it works fine up until it gets to “Removing diversion of boot/overlays/README from /boot to /usr/share/rpikernelhack/”. Then it stays there for a while, and then I get “Error Oops 17 PREEMPT SMP ARM unable to handle kernel null pointer dereference at virtual location” and a long stack trace. The only thing I can do then is pull the power. After it restarts, it wants to do the installation again, but this time it completes. However now it skips installing a bunch of stuff and instead says “dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.’”

After “completing” the install, I tried both apt-get and using dietpi-software to install software, but I only get the message above. So of course i ran dpkg --configure -a, and it started saying “no diversion of” on a bunch of things, then it got to “removing diversion of ads7846-overlay” and then “bmp085_i2c-sensor-overlay”, and then it just stops there. I’ve let it sit for hours, but it never continues. If I reboot at this point, it won’t boot and I have to flash the microSD card anew.

I’ve tried using max_usb_power with a 2A power supply and also tried to underclock the Pi, but neither of those helped. Unplugging the USB HDD before hitting Go Start Install didn’t help either.

In my most scientific ways, I experimented with completing the install, and then clearing out /boot/diversions, and now dpkg --configure -a reported “no diversion” on everything, and dietpi-software let me install PiHole, but sometime during the installation, the Pi shut down and didn’t want to boot back up.

So yeah. I’m not really sure what’s going on or how to fix this. Any ideas? Thanks!

Update: Found the problem! For anyone else who has the same problem, it worked fine once I switched microSD card (from a 4gb Kingston to a 2gb Crucial).

Hi Acriax,

Great to hear you resolved the issue.
I’ve had many many issues with failing flash media, and, I know how annoying and random it can be. So good job finding the cause.