(resolved) PiHole AdBlocker

Never had any issues, I SSH’ed into DietPi today it said there was an update v90 to v92 applied update it, restarted now Pi Hole is not working. Running this command ps aux | grep -ci [d]nsmasq returns 0.

I didn’t assign a static IP to it, my router gives it a static by MAC address so not sure if that has anything to do with it. Been using it like this for a while until this update. Any help would be appreciated.

Hi dv8ed,

We had a few other users reporting the same issue. A patch has been released with DietPi v93 to resolve this.

Simply run the following to update your system:

dietpi-update

Reboot and dnsmasq will be fixed.

Thank you that worked!

Looks like this issue is back again. I was on v119 updated to v125, reboot now Pi-Hole is not working again.
I ran ps aux | grep -ci [d]nsmasq it returned 0.

Update: I backed up my whitelist.txt, wiped, imaged DietPi & re-installed PiHole again it was quick less than 10 mins to get it up and running again. Probably something during update broke again like last time. Still love DietPi since it’s so light on resources.