(resolved) Help - Raspcontrol

Hello, thanks for the amazing system that DietPi is.

I’m trying to implement a small headless server using DietPi and need two things:

  1. Web based file manager, which I’m able to use just fine with elfinder and the LESP software, it works great.
  2. A web based control center, and I like it to be raspcontrol: https://github.com/harmon25/raspcontrol

However, I’m not able to start it, I’ve used the included webservers and nothing happens.

Even tried a few tutorials on how to do it but with no success.

However, in stock raspbian works just fine following this guide: https://menzerath.eu/artikel/raspberry-pi-raspcontrol-installation-funktionen/

But I would like to keep using DietPi.

Is there a dependancy I’m missing?



I installed LAMP using dietpi-software.

Then i created and run this code to install raspcontrol (using the guide you linked above)

wget https://github.com/harmon25/raspcontrol/archive/master.zip -O package.zip
unzip package.zip
rm package.zip
mkdir -p /var/www/raspcontrol
mv raspcontrol-master/* /var/www/raspcontrol
rm -R raspcontrol-master
chown -R www-data:www-data /var/www/raspcontrol
chmod -R 777 /var/www/raspcontrol

mkdir -p /etc/raspcontrol
cat << EOF > /etc/raspcontrol/database.aptmnt
    "user": "root",
    "password": "raspberry"
chown www-data:www-data /etc/raspcontrol/database.aptmnt
chmod 777 /etc/raspcontrol/database.aptmnt

Still cant get it to load the index/login page. It could be dependencies, however, the project Git page doesnt mention this.

Your best bet would be to contact the project devolpers. Ask them for a complete list of what additional packages (excluding LAMP) are to run their software on a debian system.

Hi, thanks for the anwer.

So I installed raspbian ua netinst, and following the guide it also works.

So comparing the base packages from that to dietpi this are the ones that are missing from dietpi

dialog groff-base initramfs-tools libuuid-perl libwrap0:armhf linux-base linux-image-3.18.0-trunk-rpi linux-image-rpi-rpfv man-db openssh-client openssh-server rsyslog vim-common vim-tiny

could it be one of those?

Can i safely installed them all?


On the other hand, do you know of a different solution, I would like to see the stats of the pi and be able to shutdown reboot from there.


Well, just tried installing al those packages and still couldn’t get it to work.

Any suggestions, I’m lost now.

Also, i read somewhere that php5 is the only requirement. Not sure if that helps. Maybe some config in dietpi related to that?.


Yep, i did a little more digging.

php5-curl is the package it requires. Running now on LAMP install.
To get Reboot and Shutdown commands to function, you will also need to install sudo.

Heres the updated code. I will add this as an install option in dietpi-software soon.
Simply install LAMP or LASP from dietpi-software, then, run the following after it reboots:

wget https://github.com/harmon25/raspcontrol/archive/master.zip -O package.zip
unzip package.zip
rm package.zip
mkdir -p /var/www/raspcontrol
mv raspcontrol-master/* /var/www/raspcontrol
rm -R raspcontrol-master
chown -R www-data:www-data /var/www/raspcontrol
chmod -R 755 /var/www/raspcontrol

mkdir -p /etc/raspcontrol
cat << EOF > /etc/raspcontrol/database.aptmnt
    "user": "root",
    "password": "raspberry"
chown www-data:www-data /etc/raspcontrol/database.aptmnt
chmod 750 /etc/raspcontrol/database.aptmnt

apt-get install sudo -y

#REQUIRES php curl
apt-get install php5-curl -y

To access webpage:
username = root
password = rapsberry

Raspcontrol will be available as a installation option in dietpi-software in the next release (v77)

Hi, thanks for the support.

Just tried on a fresh install with LASP package and followed your script but still not working. Still need to test LAMP.

I think I will wait for the new release with your script.

Thank you so much.

Edit: Just tried LAMP, stil not working so will wait for release.

Hi, just wanted to confirm it’s working for you… because I don’t seem to be able to do it, even using the script from your testing repo.

Also a quick question… is there a way to call your dietpi-software script from another script, say I have a script to install some extra software and want to do everything automatically, so it calls to the installation of say LAMP inside your script.

Finally, I have a suggestion, how about adding an overclock stress test to the stress test menu, I know there’s a couple of ways, I’m currently using this script:

#Simple stress test for system. If it survives this, it's probably stable.
#Free software, GPL2+

echo "Testing overclock stability..."

#Max out the CPU in the background (one core). Heats it up, loads the power-supply. 
nice yes >/dev/null &

#Read the entire SD card 10x. Tests RAM and I/O
for i in `seq 1 10`; do echo reading: $i; sudo dd if=/dev/mmcblk0 of=/dev/null bs=4M; done

#Writes 512 MB test file,  10x.
for i in `seq 1 10`; do echo writing: $i; dd if=/dev/zero of=deleteme.dat bs=1M count=512; sync; done

#Clean up
killall yes
rm deleteme.dat

#Print summary. Anything nasty will appear in dmesg.
echo -n "CPU freq: " ; cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
echo -n "CPU temp: " ; cat /sys/class/thermal/thermal_zone0/temp
dmesg | tail 

echo "Not crashed yet, probably stable."

Seems to work ok, but takes quite a while.



Did some further testing. Raspcontrol will only work if openssh-server is installed. It simply “hangs” with Dropbear. I have no idea why, but it must be some of the raspcontrol code expecting to have openssh-server installed.

Benchmark. Thanks, i’ll take a look.

DietPi-Software does not currently support input variables (eg: dietpi-software install KODI). Maybe in the future, however, i’d like to convert dietpi-software into a SQL database 1st.

Hi, thanks so much for the support.

Will try with openssh.

Another question, which webserver do you recommend? based on being light, I just need it for raspcontrol and the file manager, LASP or LESP?.

Also, not sure if a bug or intended, but when setting the overclock profile to extreme the core_freq is set to 400 instead of 500 as supposed to be with the profile:
sed -i ‘/core_freq=/c\core_freq=400’ /DietPi/config.txt



I would recommended using LASP/LAMP with DietPi. Whilst nginx may be “faster”, it doesnt have supported installations like Apache2 does (eg: apt-get install owncloud (requires apache2).
Using LESP LEMP is recommended for advanced users who wish to setup their websites manually.

Good spot on the overclock bug, will be fixed in next release (hopefully today if all goes well) :slight_smile:

And sure enough, it WORKS!

Running on LASP + openssh + sudo.

Thanks so much.

Great to hear.

v77 has now been released.
Run dietpi-update to upgrade.

Awesome, just tried and it´s working. Although it doesn’t install openssh by default or gives a warning. No biggie though.


Also, would you be interested in making pyload and option to install?. I kinda know a way to “automatically” set it up very easy. Let me know.

Thanks again.