Removal of Pi-Hole removed IP command. Stuck in boot net wait

Raspberry Pi 3B+
Official Power Supply
SanDisk Ultra MicroSD Card

I’ve recently installed Pi-Hole, PiVPN and Aria2 on a system that currently runs Sonarr and Radarr. After installation, Sonarr and Radarr both stopped working. Suspecting that Pi-Hole is the culprit, I tried uninstalling along with its dependencies. With infinite boot net wait time, the RPi is now stuck and can’t boot. Any suggestions on how to resolve this is much appreciated!


looks like there is something more broken on your system as you are missing some essential commands like ip

basically it is part of iproute2 apt package. But hard to check as long as you don’t have access to the system, Let’s check what has been set inside dietpi.txt. Can you remove SD card and plug it into a computer. Check dietpi.txt and search inside for following section

# Delay boot until network is established: 0=disabled | 1=10 second wait max (default) | 2=infinite wait

Probably you have set network wait to 2. Means it will wait until a valid network connection. But as you missing ip, this is not going to happen. Try to set it to 1 or 0. This should allow the system to boot. Even if network will not work probably.

Thanks! I’m now able to boot into my RPi.

My next problem now is that I can’t install iproute2 since it doesn’t recognize that I have internet. I understand that this is no longer an issue concerning DietPi but do you have any suggestions on how I could establish connectivity on it again? Or would an OS reinstall be simpler?

depends how much time you like to invest to get it solved compare to the time it will take to setup a new system :wink:

At least you could give it a try to install iproute2 offline.

  1. download the missing package to your computer
  2. connect SD card to your computer and copy the file to BootFS
  3. plug SD card back into your RPi and boot the system
  4. once login go to cd /boot
  5. try to install the iproute2 package
  6. reboot your system

But before going that way, let’s check status of needed packages. Maybe ther is something more missing :wink:

dpkg -l ifupdown iproute2 isc-dhcp-client

Got it back online after following your advice!

If anyone else experiences the same thing that happened to me, the top answer here helped guide me on how to download the missing packages.

I ran this before everything else and it returned that iproute2 and isc-dhcp-client were not installed but later found out that ifupdown was also not present in the system.

dpkg -l ifupdown iproute2 isc-dhcp-client

On a seperate RPi, i plugged in a USB flash drive and downloaded the three missing packages using

apt-get download <package name>

and used that drive to install on the RPi in question that has RootFS running on an external drive.

After all that, networking is now back up! Thanks for the help, Joulinar. Much appreciated!


good you are back online. If you don’t have a 2nd RPi at hand, you could download the package directly from their web site :slight_smile: