Reliability issues

I’ve been running Raspberry Pi’s doing various things for the last few years and never had any reliability issues. I really love the idea of DietPi but I cannot seem to get any of my setups lasting for more than a couple of weeks.

My latest setup was a LAMP setup with NextCloud setup with LetsEncrypt. All was good, but one day it stopped working and now I cannot login. I usually login over SSH with keys without needing a password, but this is not working and it keeps saying my password is incorrect.

I can still ping the Raspberry Pi
Accessing my websites I get an empty directory listing with no site
I cannot login over SSH

Any idea what is happening?

A similar thing has happened over 10 times over the past couple of months, its getting a bit of a drag now and I’m thinking I need to go back to Raspbian and install things the hard way.


I tried ssh’ing in, FTPing in, connecting a serial console cable, connecting a monitor. Could get nothing out of it.

So I pulled the plug, connected a monitor and rebooted, this is what I got. Any idea?

Hi Keith,

Unfortunately, the I/O errors indicate a filesystem corruption/disk failure. This can be caused by any of the following:

  • Loss of power whilst the device is accessing SD card (eg: powered on and unplugged)
  • Insufficient and/or unstable PSU.
  • Faulty or unstable SD card (eg: generic chinatown cards)
  • Bad SD card connection in SD card slot on RPi (eg: dust on contact areas, not inserted fully)

Can you please confirm the following, prior to the failed boot occurring:

  • Power supply used (eg: offical RPi 3 5.1v/2.5a)?
  • SD card used (eg: Sandisk Extreme UHS-3)?
  • USB harddrive used and power rating (eg: Hitachi 700ma)?
  • Additional USB connected devices, if any (eg: USB mouse / keyboard etc)?
  • Raspberry Pi Model used (eg: 3)?

Would you also be willing to save your current SD image and send over so we can test? If you need help with this, let me know and i’ll walk you through it.

Ok, earlier in the week I did a completely new setup with a different Raspberry Pi (Pi 2 model B) new SD card fresh download of DietPi and exactly the same thing has happened. I’m going back to Raspbian, this just is not usable.

It’s a 2000mA supply, purchased from The Pi Hut and came as part of a kit with my Pi3. I’m now using it on a Pi2 and get the same issue. It has been powering Raspbian installed for months on end with no issues.

  • SD card used (eg: Sandisk Extreme UHS-3)?

Kingston HC 4GB Class 4

  • USB harddrive used and power rating (eg: Hitachi 700ma)?

Western Digital 500GB MyBook, externally powered.

  • Additional USB connected devices, if any (eg: USB mouse / keyboard etc)?

915MHz RF transmitter, connected to GPIO pins (for swithcing RF sockets) Been using them on Raspbian for over one year with no issues.

  • Raspberry Pi Model used (eg: 3)?

I was using a Pi3 but now using a Pi2, exactly the same issue with both Pi’s

Would you also be willing to save your current SD image and send over so we can test? If you need help with this, let me know and i’ll walk you through it.

Yes I would

Hi Keith,

Thanks for the info.

I’ll regenerate our RPi image tomorrow and upload. Would you be willing to test stability of this image for us?

Yes I would, do you still want a concrete g of my image?


Hi Keith,

Please, if possible.

I’ve updated the RPI image, you can download it here:

Let us know if you experience any issues with the new image.

To read your SD to image (assuming Windows):

  • download Win32 Disk Imager download |, install and run.
  • Insert SD
  • Ensure the path is the SD card (eg: D:)
  • Click the open path button (right of white textbox)
  • Find a place to save image, and give it a filename
  • Click Read
    The image is now being saved to a .img file.

Once the image is read, it needs compressing, so please compress the image with 7zipor zip. Once done, please send me an email to and i’ll setup a place for you to upload your image.

Thanks Keith.

Ok, I’m downloading the updated image now. I’ve been trying to create an image from my non working SD card, but it only copies the /boot directory. I’m using a Mac and Linux and i’ve been using the dd command. When I put the non-working SD card into my Mint machine is says it cannot mount the main partition, I get a “wrong fs type, bad option, bad superblock” error message.


I have had the same experience, for me it turned out that the SD card was unreliable.
I was using a new Verbatim 64GB Class 10 SD card.
Formatted and stuffed with an image, the Raspi worked fine for a short couple of weeks.
Suddenly he kept being ping-able, other services were down and a reboot failed with unrecoverable blk errors.
Reformatted the card, reinstalled image, Raspi worked for two weeks and went down again.
After a third similar try, I dropped the card and utilized a cheap 16GB SanDisk.
No more trouble.


I’ve had this happen a couple more times now. I’ve ordered some more SD cards, so far gone through about 8 SD cards. So far I have linked this problem this to one of the following:

  1. NextCloud
  2. Fail2Ban
  3. CertBot
  4. Lets Encrypt.

It worked fine for weeks running a web server, Wiring Pi, Open Hab etc. I install the above and it breaks after one week.

I’m trying again now but this time going to try OwnCloud to see if I have more luck.


Hi Keith,

Very strange.

Probably nothing, but it might be worth increasing the swapfile size, just incase any of those program has a reoccurring memory leak. Can be done in

  • dietpi-config > Advanced Options > Swapfile (try max size)

Then see if it runs stable for a longer period. You can also use htop to check for current resource usage.

Failing that:
It could be possible your SBC has a hardware failure, although, I wouldn’t come to that conclusion until you are able to test with the following to exclude SD/PSU:

  • Sandisk Ultra/Extreme (I personally use Sandisk only, had issues with other brands over the years and especially the cheap China-town ones)
  • Offical RPi PSU

Fingers crossed, all seems to be working now. I’ve reverted back to ownCloud rather than NextCloud though.

Excellent, thanks Keith. Please keep us updated of any issues, if/when they occur.