Radxa Zero SD Card not accessible after mounting the image

Hi Everyone,

I was an user of dietpi for my Rpi zero 2w, but with the lack of rpi on the market, i decided to give a try to the radxa zero.

Unfortunatelly, after building the dedicated image of dietpi for the radxa zero, i can’t acces files on my sd card using windows.
If I put my sdcard on the radxa zero, os doesn’t load.

I tried with an other sd card and it gave me the same result.

(If I build the image dedicated to rpi, i can properly access files)

Can someone help me about that?

Thank you !

Welcome to our community.

This is as expected as your entire SD card is using ext4 file system format. And Windows is not able to read ext4 out of the box.

On the other hand, for RPI we have a dedicated fat partition hosting the boot file system (only). Therefore, you are able to read the /boot directory on your Windows box.

Thank you for you answer !

I need to access my SBC with SSH so i see 2 options:

  • edit my sd card so i can add a preconfigured dietpi.txt and wifi ==> but can’t find a soft with success on windows 10)
  • boot the radxa with a default dietpi config and set it up after ==> but i have a black screen !

Thank you

Or you create another Linux box (could be a VM) and attach the SD card to be able to adjust settings.

Thank you for your suggestion, i managed to configure the boot. :ok_hand:

I still have an issue with the boot (black screen)… I will try with a different model of sd card…

BTW: did you tried our image we provide already? https://dietpi.com/downloads/images/DietPi_RadxaZero-ARMv8-Bullseye.7z

Or what do you mean by building a dedicated image?

This is the image i’m using.

Tried with 2 differents radxa Zero and Hdmi cable.
Same result…

SD card is a 32Go High Endurance from SanDisk (tried with 2 of them)

Tried with a 32go SanDisk Ultra and I was able to boot !
But (obviously it can’t run properly…) I can’t load wlan0 …

are you able to login physically to that device?

I’m able to use eth0.

But that’s not the way i need to use it :frowning:

I tried using an armbian image, but same result… no wifi…

Have a look to GitHub. There was some research on WiFi done. Maybe it helps Image | Radxa Zero · Issue #4831 · MichaIng/DietPi · GitHub

I tried the different step in your link ( and some other found by searching on the web)
No success…

I gave a try to the official ubuntu server and it worked…

I would have prefer to be on dietPi… but I’m happy to see the wifi working now.

We are now away of the initial topic…

Thank you for you help!

@MichaIng FYI an issue using WiFI on Radxa Zero

Is it still an issue with latest image/kernel? I’m not aware of any issues with WiFi, also no reports on Armbian forum. The linked GitHub comment was about setting up WiFi on the original Radxa Debian image, not related to any final DietPi image, especially not the new ones based on Armbian.