Question about DietPi v8.14 for odroid N2+

Hi I just saw that v8.14 Release Notes for N2/N2+ image now can be boot from SPI Petitboot , Do I need extra step to make it works or i can just type netboot_default to install the new image to external ssd or i need to burn the new image to external ssd ?

Something @MichaIng might be able to help with.

I’ve not experience with netboot and what this command is supposed to do. You need to flash the new image to the USB drive with whichever way you’d normally do, then switch the hardware toggle to “SPI” and power it. If it does not work OOTB, try to update petitboot to lastest version. We have quite some cases where it does not work (yet), so it is not as reliably as I was hoping, but it does work reliably on my Odroid N2+ :wink:.

With some adjustments you can also clone your current SD card/eMMC image to the USB drive and make it USB-boot ready. But it probably makes sense to test with a fresh image first.

1 Like

Already tried two of my N2+ with two different eMMC and external ssd for v8.14

Left one with original orange eMMC working without problem , But fresh install the image to WD RED external 2.5" SSD and took out the eMMC switch SPI directly boot from SSD I got initramfs screen and that’s it .

Right one with white sandisk eMMC no longer works with fresh install v8.14 , Tried install the image to my startech M.2 raid external enclosure with 2x 1TB wd blue sata M.2 in raid 0 . same no moves in initramfs screen .

EDIT: Since the other topic is so long, lets keep discussion here.

All images are DietPi v8.14. Both images (Bulllseye and Bookworm) below the testing sub directory are shipped with Armbian’s U-Boot (EDIT: I just see I didn’t built Bookworm with it), the two ones in the parent directory are with the U-Boot build which worked for you before, and has not changed. There is neither a difference between Bullseye and Bookworm, nor between DietPi v8.14 or other versions in this regards.

Can you show the log messages before initramfs prompt? There was no other drive or card attached at that time? In my case, with eMMC and SPI switch, it didn’t even reach initramfs or kernel stage: after the autoboot timeout of petitboot ended, it just did nothing. That all shows me that booting via petitboot seems highly unreliable, at least with mainline kernel.

I haven’t try to boot emmc from spi switch , Because i thought i can boot directly from external ssd without attached anything . The point is if i can boot eMMC from MMC why should i switch to boot from SPI ?

I hoping dietpi can boot directly on external SSD just like i can boot debian on external ssd with netboot_default

If you want to use petitboot you need to boot from SPI.

A post was split to a new topic: DietPi-Led_control does not work

That is right, there absolutely no reason to boot via SPI when the OS is on SD card or eMMC. So this is just relevant for Odroid HC4 (which has no SPI/MMC switch but a MASKROM button only) and for testing purpose.

You mean Debian in x86_64 with GRUB bootloader? That’s a completely different thing, of course :smile:. Yeah, the petitboot support was meant to enable USB boot without further modifications, but while it works perfectly fine on my N2+, it seems to be generally very unreliable.