qBittorrent login issue

hi, i upgrated my dietpi to lastest version today and reinstalled softwares. after qbittorrent install, i cannot login on webgui. tried different combinations;

qbittorrent / dietpi
qbittorrent / adminadmin
qbittorrent / myglobalpass
root / dietpi
root / adminadmin
root / myglobalpass

no result.

searched forums, tried to config qbittorrent.conf webgui password line. nothing.

please help me to find right solution.

qbittorrent / dietpi still works for me on latest updates :man_shrugging:

I could replicate the issue. Even removing the user and password from the config file and restarting the service didn’t allow me to login the web UI: https://github.com/qbittorrent/qBittorrent/wiki/Web-UI-password-locked-on-qBittorrent-NO-X-(qbittorrent-nox)
But also there is no wrong user/password warning, so it seems to be another issue actually. Is that true in your case as well when you use qbittorrent / myglobalpass?

Hah, tried it with another browser (Edge) and there it worked. On Opera it still does not…
Logged in with Edge with default user/password (admin/adminadmin) after removing user and password lines from config + restart. Then adjusted both in web UI and compared to how we add it in dietpi-software: Exactly the same!

So it seems to be a browser specific issue. Please verify that this is the case for you as well (e.g. it works with Microsoft Edge). Then we need to report to qBittorrent devs.

you are right Michalng thank you.
hust tried on edge, and its ok with qbittorrent / dietpi
still cant login on chrome.

Ref: https://github.com/MichaIng/DietPi/issues/2861

No issue on Buster systems, so it is resolved with current qBitTorrent versions. Will report this to the Debian bug tracker, perhaps it is reason enough to update the version in Stretch repo. Otherwise we probably need to ship custom compiled binaries.

I will add the info to our online docs for now: https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/68

I installed qbittorrent today and tried to login with Chrome, Edge and Firefox all give a warning ‘username and/or password incorrect’ after sometime my ip get banned. I used
admin - adminadmin,
qbittorrent - dietpi,
qbittorrent - adminadmin,
qbittorrent - myglobalpassword

and also tried root as username

nothing worked for me.

I have the same issue with a fresh install…

With me also the same problem.
I changed the password under qbittorrent / .config

But no success no registration possible.

well… In my installation there was no configuration file, and the login didn’t work.
So I’ve taken the following steps to make it work:

1.- Connect by SSH to your device.
2.- Execute:

qbittorrent-nox default

The default user name and password will now appear, and the service will be running on port 8080. Access to your IP:8080, with the credentials that qbitorrent has indicated, login and change the password from the configuration.

Now you can kill the qbitorrent-nox service (Ctrl+C) and restart the device services:

dietpi-services restart

Now you can access to the service with:

user: qbittorrent

I hope I’ve explained well… :face_with_raised_eyebrow:

Thanks for your reports guys. I will try to replicate. Probably the way the password has to be stored changed.

issue fixed below

The config file did not exist? That is strange since it is explicitly created :thinking::


I’ll retest a fresh install later, currently I can’t see a reason why this fails, besides the mentioned Chromium login issue on Stretch systems.

qbittorrent-nox default
Note that this must be executed as user qbittorrent, which is what the service runs as, so:
sudo -u qbittorrent qbittorrent-nox default should be it, if the above file indeed was not created as expected.

Figured this out, in case anyone is still having issues here:

The systemd file is


which is, by default

Description=qBittorrent (DietPi)

ExecStart=/usr/bin/qbittorrent-nox --webui-port=8080


So the service is run as qbittorrent user by default, so the relevant prefs file is in


so just hit up a quick

cp -r ~/.config/qBittorrent/ /home/qbittorrent/.config

Hey guys, I found the bug. We used useradd -p “$GLOBAL_PW” to create the user, but this takes the password not as “raw” but as encrypted. So when login fails, please do:

chpasswd <<< 'qbittorrent:yourPassword'
echo -n 'yourPassword' | md5sum | mawk '{print $1}' # Copy this string (hashed password)
nano /home/qbittorrent/.config/qBittorrent/qBittorrent.conf

Add the hashed password here:

Thanks! Just installed the latest today and this is still an issue, after reading all the other threads I found this suggestion. It was the only thing that worked to let me in though the webui. Much appreciated! :sunglasses:

I’ve been fighting with this problem for a while now and finally yesterday after inspect the qBittorrent.conf on my home folder and the qBittorrent home folder i figure out that every time I restarted the service the password was resent to mygobalpassword :cry: :thinking: :face_with_raised_eyebrow:


So for me the username was: qbittorrent
and the password: myglobalpassword

Now I can log in normally.


I’m having the same problems now with the latest Bullseye release and Qbittorrent (just did a clean install). I’m using qbittorrent as user name and myglobalpassword as password, but I’m getting Invalid Username or Password.

Can anyone else confirm this issue?

Here’s the log for the installation:

Mode: Configuring qBittorrent: bittorrent server with web interface (c++)

[  OK  ] DietPi-Software | Verifying user "qbittorrent" to run qBittorrent
[  OK  ] DietPi-Software | useradd -rMN -g dietpi -d /home/qbittorrent -s /usr/sbin/nologin qbittorrent
[  OK  ] DietPi-Software | Applying user password: ******
[  OK  ] DietPi-Software | mkdir -p /home/qbittorrent/.config/qBittorrent /var/log/qbittorrent
[  OK  ] DietPi-Software | chown -R qbittorrent: /var/log/qbittorrent
[  OK  ] DietPi-Software | chown -R qbittorrent:dietpi /home/qbittorrent
[  OK  ] DietPi-Software | systemctl daemon-reload

looks like using qbittorrent version ≥ 4.2.0, authentication method changed. Something we need to have a look into.

As workaround, you could do following

systemctl stop qbittorrent.service
nano /home/qbittorrent/.config/qBittorrent/qBittorrent.conf

Once you are in the file, delete the entire line starting WebUI\Password_ha1. Should be somewhere at the bottom.
Restart the service afterwards

systemctl start qbittorrent.service

Default password would be adminadmin. Don’t forget to change once you are login.

That workaround was great. Working now!