Problem installing desktop LXDE


I am trying to install the LXDE desktop but there comes a point where it throws me the following error:

 Checking URL:
│  - Command: wget --spider -t 1 -T 10
│  - Exit code: 8
│  - DietPi version: v6.32.2 (MichaIng/master) | HW_MODEL: 4 | HW_ARCH: 2 | DISTRO: 5
│  - Image creator: DietPi Core Team
│  - Pre-image: Raspberry Pi OS (32-bit) Lite
│  - Error log:
│ Spider mode enabled. Check if remote file exists.
│ --2021-05-14 14:08:58--
│ Resolving (,
│,, ...
│ Connecting to (||:443...
│               Retry          : Re-run the last command that failed                 ↑
│               DietPi-Config  : Edit network, APT/NTP mirror settings etc           ▮

The Pi has URL connectivity:

root @ DietPi: ~ # ping
PING ( 56 (84) bytes of data.
64 bytes from ( icmp_seq = 1 ttl = 56 time = 46.4 ms
64 bytes from ( icmp_seq = 2 ttl = 56 time = 46.6 ms


you are running an old DietPi version. Pls update your system as the file the installation is trying to download did not exit anymore.


I would rather not have to update as I updated another PI last week and suffered data corruption.

There is no way to solve it without updating?


Ah yes, we renamed that file and forgot that the old one needs to stay for older versions.

When you face the error prompt, you can select “change command” and replace the file name in the URL with “98-dietpi-disable_dpms.conf”. That is how it is called now.

Is that a feature already working in v6.32.2? Honestly I forgot the version we introduced it :sweat_smile:

It’s just an config with the aim to disable display power management, which is not well supported by RPi and most SBCs, e.g. display turns of during video playback, Chromium kiosk, cloudshell/monitoring tools etc.

Ahh I was not clear enough :sunglasses:

I mean the error handle to allow to change command :wink:

Ah, true. At least I see a scroll bar in the error paste, so down arrow key would reveal those options.