pihole not installable (Pi 3, DietPi_RPi-ARMv8-Buster)

For now 2 days I tried to install pihole on PI 3 (DietPi_RPi-ARMv8-Buster) without any success. I did this already on Pi 2 and on Odroid C2 without any problems:

Checking URL: https://www.internic.net/domain/named.root
                              │  - Command: curl -ILfvm 10 https://www.internic.net/domain/named.root
                              │  - Exit code: 28
                              │  - DietPi version: v7.0.2 (MichaIng/master) | HW_MODEL: 3 | HW_ARCH: 3 | DISTRO: 5
                              │  - Image creator: DietPi Core Team
                              │  - Pre-image: Raspberry Pi OS Lite (64-bit)
                              │  - Error log:
                              │ * Expire in 0 ms for 6 (transfer 0x55aeea4c30)
                              │ * Expire in 10000 ms for 8 (transfer 0x55aeea4c30)
                              │ * Expire in 1 ms for 1 (transfer 0x55aeea4c30)
                              │   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                              │                                  Dload  Upload   Total   Spent    Left  Speed
                              │ ^M  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* Expire in 0 ms for 1 (transfer
                              │ 0x55aeea4c30)
                              │ * Expire in 2 ms for 1 (transfer 0x55aeea4c30)
                              │ * Expire in 0 ms for 1 (transfer 0x55aeea4c30)


                                * Closing connection 0
                              │ curl: (28) Resolving timed out after 10000 milliseconds
                              │                        Retry          : Re-run the last command that failed                 ↑
                              │                        DietPi-Config  : Edit network, APT/NTP mirror settings etc           ▮
                              │                                  <Ok>                                      <Exit>

This is what I did:

  1. Downloaded new Image from DietPi-Website, written it to SDRAM and double checked it (dcfldd …)
  2. Inserted SDRAM into Pi 3, started PI 3, updated successfully!, assigned static IP …
  3. Launched diepi-software, selected unbound and pihole, installation started (unbound without any problems, pihole cf. above!)
  4. Selected “Retry : Re-run the last command that failed” yielded the same result.
  5. I did not find any helpful hints in the logs (journalctl -f …)

Are the problems (which?) between my ears, have some links changed …?
Any ideas or hints are really appreciated.
Thank you very much!

did you try to install PiHole without unbound? The step you are failing is the unbound config where the system is trying to download unbound root server information from https://www.internic.net/domain/named.root

You have issues to resolve the host name correctly.

curl: (28) Resolving timed out after 10000 milliseconds

Maybe you can try to change DNS server on your local device pointing to one of the global DNS provider like Quad9, Cloudflare or Google DNS

Yes, I tried to install with and without unbound. No change! :frowning:

What can be the reason for this resolv problem:

  • All “apt update/upgrade” went perfect
  • I use the DNS given by my provider (did’nt change nothing!)
  • I did a clean and successful installation of pihole and unbound in a virtualbox DiePi installation on my linux workstation.
  • All use the same FritzBox! and hence the same DNS system.
    Any ideas?

Are you able to open the Domain on you desktop computer? Usually if you install Pihole without unbound, the file should not be downloaded

The Pi uses

root@DietPi:~# cat /etc/resolv.conf

and I will try to change this.

This is global Quad9 DNS and should be totally fine

Are you able to open the Domain on you desktop computer?
Which Domain do you mean?

The one which is failing https://www.internic.net/domain/named.root

This is the command you have posted above

curl -ILfvm 10 https://www.internic.net/domain/named.root

Problem solved.
I shoudn’t change the default DHCP network settings :wink:.
Thank you for your kind support