PiHole issue

just installed pihole on v135 on bananapro and i got this message on web interface

Pi-hole needs to be updated to at least v2.7 before you can use features such as whitelisting/blacklisting from this web interface!

what shall i do? thx

…The same for me, I uninstalled a previous version of pihole (installed by dietpi-software) and reran the installation (dietpi v136) and saw that it was now using the pihole install script. However, nothing seems to work very well. I am getting the same “Update available!”, but then:

root@DietPi:~# pihole -up
::: Fetching latest changes from Github…
fatal: Not a git repository (or any of the parent directories): .git
/usr/local/bin/pihole: line 59: /etc/.pihole/automated install/basic-install.sh: No such file or directory

…and also this:

root@DietPi:~# pihole -v
/usr/local/bin/pihole: line 92: /opt/pihole/version.sh: No such file or directory

(/opt/pihole/ is empty by the wat).
:-/

Hi,

As of DietPi v135, PiHole installation uses the official installer. Previous to v135, the installation used our DietPi modified fork.

Are you running Lighttpd webserver, you can check with green result from:

dietpi-software list | grep lighttpd | grep '[[:space:]]=2'

Possibly some files are left over from the uninstall, try running

dietpi-software uninstall 93
rm -R /var/www/pihole
rm -R /var/www/html/pihole
rm -R /var/www/html/admin

Say N to all PiHole option requests. Reboot system, then reinstall with DietPi-Software.

Unfortunately, at least for me this does not work. It seems the installer runs fine, but I can not see pihole running under htop, and now I can neither reach the web server!? (Just getting a “404 - Not Found” on http://192.168.0.100/pihole)

Same for me :frowning: 404 not found, and yes im using Lighttpd

Seems the address is now http://192.168.x.x/html/admin

404 not found again >_>

fresh install, but on my system Orange Pi PC status shows orange light: Starting instead of Active.

What’s wrong?

Is this related to PiHole or a more general problem?

If the latter can you start a new thread?

John

yes, this is for Pi-hole
Capture2.PNG
Capture1.PNG
Capture.PNG

Is it actually working for anyone who has performed a fresh install?

http://192.168.0.100/html/admin does not work neither (404), and as mentioned, htop does not show pihole running. Any way to use the old installer/setup?

(But typing pihole at the command promt at least show

root@DietPi:~# pihole
::: Control all PiHole specific functions!
:::
::: Usage: pihole [options]
::: Add -h after -w (whitelist), -b (blacklist), or -c (chronometer) for more information on usage
:::
::: Options:

…so something is installed, somewhere. :slight_smile:

However:

root@DietPi:~# pihole -d
/usr/local/bin/pihole: line 41: /opt/pihole/piholeDebug.sh: No such file or directory

I just did a fresh install last night and it’s working for me.

Do you see /usr/sbin/dnsmasq running in htop?

Why it wants to upgrade if it is already installed the latest version? There is the bug.

solved:

run curl -L https://install.pi-hole.net | bash (from https://pi-hole.net/)

new Web interface is: www.yourpipholeip/admin

I’ve tried it but still not working >_> and the installation from launcher warns me that the webgui is outdated

This messed up my entire PiHole installation and I basically had to reinstall DietPi from scratch…

Sorry to hear that. What system are you using?

When using DietPi to install PiHole, DietPi creates a symlink after the official PiHole installer exit’s. This is to allow a more “reasonably named link” method of accessing the web interface:

ln -sf /var/www/html/admin /var/www/pihole



Can we have the old installer back?

No.

We had a very good installation for PiHole for a long time on DietPi. Although our version was 2-4 weeks behind the official, it was stable. However, after time, users wanted the latest version instead of one that was tested for stability, worked with any webserver stack and was optimized for minimal installation footprint.

Gradually, over time, PiHole would break if the official installer wasn’t used to install it. It even uses Git to check the version (which means more disk resource usage, ours didn’t even install Git). So we had to spend alot of time trying to “fix” and patch our more optimized forked installation each PiHole update.

PiHole would also tell DietPi users the DietPi version is “out of date” and even take credit for the DietPi optimized version:
https://www.reddit.com/r/pihole/comments/43ix3f/dietpi_already_installed_pihole_can_i_just_run/czimqna/
https://www.reddit.com/r/raspberry_pi/comments/42y2v6/pihole_via_dietpi_stats_not_showing_up_not_working/czdyj7k/
https://www.reddit.com/r/pine64/comments/4upnvd/if_all_you_want_is_a_headless_server_go_for_the/d5rrgfl/
https://www.reddit.com/r/pihole/comments/46xd49/pihole_253_released/d09vsh0/

So now, we use the official PiHole installer. All bugs should be reported to PiHole directly.

This topic is now locked.